You are on page 1of 5

Search

An A-Z Index of the Apple OS X command line


alias alloc apropos awk basename bash bg bind bless break builtin bzip cal caller case cat cd chflags chgrp chmod chown chroot cksum clear cmp comm command complete continue cp cron crontab curl cut Create an alias List used and free memory Search the whatis database for strings Find and Replace text within file(s) Convert a full pathname to just a filename Bourne-Again SHell Send to background Display readline key and function bindings Set volume bootability and startup disk options. Exit from a For, While, Until or Select loop Execute a shell builtin Compress or decompress files Display a calendar Return the context of a subroutine call Conditionally perform a command Concatenate and print (display) the contents of file(s) Change Directory Change a file or folder's flags Change group ownership Change access permissions Change file owner and group Run a command with a different root directory Print CRC checksum and byte counts Clear terminal screen Compare two files Compare two sorted files line by line Run a command (not a function) Edit a command completion [word/pattern/list] Resume the next iteration of a loop Copy one or more files to another location Daemon to execute scheduled commands Schedule a command to run at a later date/time Transfer data from or to a server Divide a file into several parts

date Display or change the date & time dc Desk Calculator dd Data Dump - Convert and copy a file declare Declare variable & set attributes defaults Set preferences, show hidden files df Display free disk space diff Display the differences between two files diff3 Show differences among three files dig DNS lookup dirname Convert a full pathname to just a path dirs Display list of remembered directories diskutil Disk utilities - Format, Verify, Repair disown Unbind a job from the current login session ditto Copy files and folders dot_clean Remove dot-underscore files drutil Interact with CD/DVD burners dscacheutil Query or flush the Directory Service/DNS cache dseditgroup Edit, create, manipulate, or delete groups dsenableroot Enable root access dsmemberutil View user and groups rights dscl Directory Service command line utility du Estimate file space usage echo ed enable env eval exec exit expand expect Display message on screen A line-oriented text editor (edlin) Enable and disable builtin shell commands List or Set environment variables Evaluate several commands/arguments Execute a command Exit the shell Convert tabs to spaces Programmed dialogue with interactive programs

export expr false fc fdisk fg file find fmt fold for fsck fsaclctl fs_usage ftp

Also see AppleScript Set an environment variable Evaluate expressions Do nothing, unsuccessfully Fix command (history) Partition table manipulator for Darwin UFS/HFS/DOS Send job to foreground Determine file type Search for files that meet a desired criteria Reformat paragraph text Wrap text to fit a specified width Loop command Filesystem consistency check and repair Filesystem enable/disable ACL support Filesystem usage (process/pathname) Internet file transfer program

GetFileInfo Get attributes of HFS+ files getopt Parse positional parameters getopts Parse positional parameters goto Jump to label and continue execution grep Search file(s) for lines that match a given pattern groups Print group names a user is in gzip Compress or decompress files halt hash head hdiutil history hostname iconv id if info install jobs join Stop and restart the operating system Refresh the cached/remembered location of commands Display the first lines of a file Manipulate iso disk images Command History Print or set system name Convert the character set of a file Print user and group names/id's Conditionally perform a command Help info Copy files and set attributes List active jobs Join lines on a common field

j k

kextfind List kernel extensions kickstart Configure Apple Remote Desktop kill Stop a process from running l List files in long format (ls -l) last Indicate last logins of users and ttys launchctl Load or unload daemons/agents ll List files in long format, showing invisible files (ls -la) less Display output one screen at a time let Evaluate expression lipo Convert a universal binary ln Make links between files (hard links, symbolic links) local Set a local (function) variable locate Find files logname Print current login name login log into the computer logout Exit a login shell (bye) lpr Print files lprm Remove jobs from the print queue lpstat Printer status information ls List information about file(s) lsregister Reset the Launch Services database lsbom List a bill of materials file lsof List open files man mdfind mdutil mkdir mkfifo more mount mv Help manual Spotlight search Manage Spotlight metadata store Create new folder(s) Make FIFOs (named pipes) Display output one screen at a time Mount a file system Move or rename files or directories

net Manage network resources netstat Show network status networksetup Network and System Preferences nice Set the priority of a command nohup Run a command immune to hangups ntfs.util NTFS file system utility onintr Control the action of a shell interrupt open Open a file/folder/URL/Application opensnoop Snoop file opens as they occur osacompile Compile Applescript osascript Execute AppleScript passwd paste pbcopy pbpaste pico ping pkgutil plutil pmset popd pr printenv printf ps pushd pwd quota rcp read readonly reboot return rev rm rmdir rpm rsync Modify a user password Merge lines of files Copy data to the clipboard Paste data from the Clipboard Simple text editor Test a network connection Query and manipulate installed packages Property list utility Power Management settings Restore the previous value of the current directory Convert text files for printing List environment variables Format and print data Process status Save and then change the current directory Print Working Directory Display disk usage and limits Copy files between machines Read one line from standard input Mark a variable or function as read-only Stop and restart the system Exit a function Reverse lines of a file Remove files Remove folder(s) Remote Package Manager Remote file copy - Sync file tree (also RsyncX)

q r

say Convert text to audible speech screen Multiplex terminal, run remote shells via ssh screencapture Capture screen image to file or disk sdiff Merge two files interactively security Administer Keychains, keys, certificates and the Security framework sed Stream Editor select Generate a list of items set Set a shell variable = value setfile Set attributes of HFS+ files shift Shift positional parameters shopt Set shell options shutdown Shutdown or restart OS X sips Scriptable image processing system sleep Delay for a specified time softwareupdate System software update tool sort Sort text files source Execute commands from a file split Split a file into fixed-size pieces stop Stop a job or process su Substitute user identity sudo Execute a command as another user sum Print a checksum for a file suspend Suspend execution of this shell sw_vers Print Mac OS X operating system version system_profiler Report system configuration systemsetup Computer and display system settings tail tar tee test Output the last part of files Tape ARchiver Redirect output to multiple files Condition evaluation

textutil Manipulate text files in various formats (Doc,html,rtf) time Measure Program Resource Use times Print shell & shell process times top Display process information touch Change file timestamps tr Translate, squeeze, and/or delete characters trap Execute a command when the shell receives a signal traceroute Trace Route to Host true Do nothing, successfully tty Print filename of terminal on stdin type Describe a command ufs.util ulimit umask umount unalias uname unexpand uniq units unset until uptime users uuencode uudecode uuidgen uucp vi wait wc whatis where which while who whoami write xargs yes !! Mount/unmount UFS file system limit the use of system-wide resources Users file creation mask Unmount a device Remove an alias Print system information Convert spaces to tabs Uniquify files Convert units from one scale to another Remove variable or function names Loop command Show how long system has been running Print login names of users currently logged in Encode a binary file Decode a file created by uuencode Generate a Unique ID (UUID/GUID) Unix to Unix copy Text Editor Wait for a process to complete Print byte, word, and line counts Search the whatis database for complete words Report all known instances of a command Locate a program file in the user's path Loop command Print all usernames currently logged on Print the current user id and name (`id -un') Send a message to another user Execute utility - passing arguments Print a string until interrupted Run the last command again

v w

Commands marked are bash built-in commands. OS X Panther 10.3, Tiger 10.4 and Leopard 10.5 default to running the bash shell, this runs under 'Darwin' the open source core of OSX. OS X Man Pages - Apple Developer Connection Discussion forum Links to other Sites, Books etc... Mac OS X is a rock-solid system that's beautifully designed. I much prefer it to Linux - Bill Joy

Copyright SS64.com 1999-2011 Some rights reserved

You might also like