You are on page 1of 3

1.

What is the default location of cron job entry in AIX


Ans: By default cron searches its spool area /var/spool/cron/crontabs directory for
crontab files. Note: In this location, the cron entry file will be made for each user in AIX.

2. How to increase an existing filesystem size in AIX. Also, what should be done if the
filesystem is not getting increased due to restriction of maximum no. of Logical Partitions
in Logical Volume.
Ans: #chfs a size=+<size> /<filesystem>

For eg: #chfs a size=+2G /filesystem-name
Note: If the filesystem does not get increased, then we need to increase the number of
LPs in the LV of that filesystem by using, #chlv x <no. of LPs> <LV name>

3. What is the default user in HMC
Ans: hscroot and the password is abc123

4. How to mount a CD in AIX
Ans: #mount V cdrfs o ro /dev/cd0 /mnt

5. How to check the account locked status of all users
Ans: # lsuser -a account_locked ALL

6. What will you do if you are not able to login into an AIX Server, which is one of the
LPAR in a managed system
Ans: If we are not able to login into an AIX server, then we have to login into the HMC
and open a console session for that particular LPAR. Then, we need to login as root in the
LPAR (AIX server), and check whether the ssh service is running or not by using
#lssrc s sshd
If it is not running, then we need to start the sshd service by using
#startsrc s sshd
Also, we have to ensure the sshd line in /etc/inetd.conf file is uncommented

7. How to unlock an user in AIX
Ans: #chuser account_locked=false <username>

8. How to reset the account of an user in AIX
Ans: # chsec -f /etc/security/lastlog a "unsuccessful_login_count=0" -s <username>

9. What is the command for mapping a disk from VIO Server to LPAR client
Ans: # mkvdev -vadapter <virtual adapter name> -vdev <Backing device name> -dev
<VTD name>
Note: VTD Virtual Target Device

10. How to view all installed packages in AIX
#lslpp l

11. How to install the packages in a CD using command line
#installp agXd </dev/cd0 > <package-name>

Note: The flags used are: a for installing in applied state, g for pre-requisites, X
for expansion of /tmp filesystem if needed, d for specifying device

12. What are the basic daemons for the cluster in AIX
Ans:
The Cluster Manager (clstrmgrES) daemon
The Cluster Communications (clcomdES) daemon
The Cluster Information Program (clinfoES) daemon

13. How to check the statistics of a network interface in AIX
#entstat en0


14. How to increase the maximum number of running processes in a system
#chdev l sys0 a maxproc=<no. of processes>

15. How to increase the paging space
#chps s <no. of LPs> <paging_space_name>

16. How to decrease the paging space
#chps d <no. of LPs> <paging_space_name>

17. What are the steps to be followed in case of a corrupted BLV

If a Boot Logical volume (BLV) is corrupted, a machine will not boot.
(Eg:bad block in a disk might cause a corrupted BLV)

To fix this situation, You must boot your machine in maintenance mode, from a CD or
Tape. If a NIM has been setup for a machine, you can also boot the machine from a NIM
master in maintenance mode.

The bootlists are set using the bootlist command or through the System Management
Services Progam (SMS). pressing F1 will go to SMS Mode.

then change the bootlist for service(maintenance) mode as 1st device to CD ROM.

#bootlist -m service cd0 hdisk0 hdisk1

then start maintenance mode for system recovery,

Access rootvg,

access this volum group to start a shell,

then recreate BLV using bosboot command.

#bosboot -ad /dev/hdisk0

it's important that you do a proper shutdown, All changes need to be written from
memory to disk.

#shutdown -Fr

Imp: bosboot command requires that boot logical volume hd5 exists. If you wan create a
BLV ( may be it had been deleted by mistake ), do the following,

1. boot your machine in maintenance mode,
2. Create a new hd5 logical volume, one PP size, must be in rootvg,specify boot as
logical volume type,

#mklv -y hd5 -t boot rootvg 1
3. Then run bosboot command as described.

18. Tell about boot process in AIX
Ans:
After POST, the firmware (System Read Only Storage) detects the 1st bootable
device stored in the bootlist. (here it is hdisk0)
Then the bootstrap code (software ROS) i.e. 1st 512 bytes of the hard disk loads
to RAM.
Bootstrap code locates the Boot Logical Volume (BLV = hd5) from the harddisk
BLV contains AIX kernel, rc.boot Script, Reduced ODM and Boot commands.
Then BLV in the RAM uncompresses and Kernel releases from it.
Then AIX Kernel gets control.
AIX Kernel creates a RAM File System (Rootvg not activated now).
kernel starts init process from the BLV.
init executes rc.boot script from the BLV in the RAM.
Init with rc.boot 1 configures base devices.

You might also like