You are on page 1of 6

Qos Implementation Guide on Cisco Routers Page 1

QoS Implementation Guide on Cisco Routers


Date: 8/1/01
Author: Brent Wilson
Last Revised: 10/15/01


Introduction

This is a living document that briefly describes MOREnets current QoS solution, and
how it is implemented in the router. This document will also briefly explain how to
determine that the QoS policy is working.

Low-Latency Queuing

Low-Latency Queuing (LLQ) is a mixture of Priority Queuing (PQ) and Class-Based
Weighted-Fair Queuing (CBWFQ). It is currently the recommended queuing method for
Voice over IP (VoIP) and IP Telephony, and it will also work well with video
conferencing.

The priority queue takes all packets that meet the definition defined by a class map and
applies a policy to them. In MOREnets Low-Latency Queuing strategy, we take all
packets marked with IP precedence 5, and we make sure they are sent out of the routers
serial interface first before any other packets or queues are acted on.

IP Precedence

There are 7 levels of IP precedence:

111 = Network Control = Precedence 7 (Link layer & routing protocol keep-alive)
110 = Internetwork Control = Precedence 6 (used for IP Routing protocols)
101 = Critical/Express Forwarding = Precedence 5
100 = Flash Override = Precedence 4 (Class 4)
011 = Flash = Precedence 3 (Class 3)
010 = Immediate = Precedence 2 (Class 2)
001 = Priority = Precedence 1 (Class 1)
000 = Routine = Precedence 0 (Best Effort)

Precedence 6 and 7 has the highest precedence, and is used for Network Control, such as
routing protocol updates and link keep-alive frames. Precedence 5 is used for the most
critical or highest priority traffic, such as interactive audio and video. The other priorities
are used depending on how you wish to prioritize your traffic.



Qos Implementation Guide on Cisco Routers Page 2
All traffic not entering the priority queue goes into other queues based upon their ip
precedence or class as defined in the class map. The higher the precedence, the higher the
queue the packet goes to. Each queue is weighted so that the higher numbered queues are
serviced first. If there is congestion the lower numbered queues will start dropping
packets to allow the higher queues to send their traffic.

Low-Latency Queuing






Sample Router Configurations

Low-Latency Queuing

7204 routers, or 1720, 2600, and 3600 routers running IMA

These routers with IMA or ATM must have the policy applied to the vc under the logical
interface.

ip cef
!
class-map match-any Video
match ip precedence 5
!
!
policy-map Video
class Video
priority 1000
class class-default
fair-queue 16



Qos Implementation Guide on Cisco Routers Page 3



interface ATM2/0.100 point-to-point
description ATM Link to MOREnet
bandwidth 45000
ip address 10.1.1.2 255.255.255.252
no ip mroute-cache
pvc 2/100
abr 45000 45000
encapsulation aal5snap
service-policy output Video


1601, 1720, 2500, 2600, 3600 routers with standard Serial or HSSI interfaces

These routers need an access list applied to the physical interface to implement the QoS
policy.

!
class-map Video
match access-group 100
!
!
policy-map Video
class Video
priority 512
class class-default
fair-queue
!
ip cef
!
interface Serial0
ip address 10.1.1.2 255.255.255.252
encapsulation frame-relay IETF
service-policy output Video
frame-relay interface-dlci 100
!
access-list 100 permit ip any any precedence critical






Qos Implementation Guide on Cisco Routers Page 4
IOS Version Needed to Implement QoS

To implement Low-Latency Queuing, you must have Cisco-Express Forwarding enabled
on the router. Therefore, the version of IOS must be at least IP Plus or higher. Cisco
states that the version of IOS must be at least 12.0.7.

We use the IOS versions for the following platforms:

1600 12.0.7 IP PLUS c1600-sy-l.120-7.T.bin
1700 12.1.9 IP PLUS c1700-sy-mz.121-9.bin
2500 12.0.7 IP PLUS c2500-i-l.120-7.T.bin
2600 12.2.2 IP PLUS c2600-i-mz.122-2.T1.bin

3600 We currently use version 11.3 for the modem pools, but if we use the 3620 as the
edge device it will need to be at least version 12.0.7 to use Low-Latency Queuing.

7200 12.1.9E DESKTOP c7200-ds-mz.121-9.E.bin

Verifying QoS Operation

Verifying QoS from the router command line is accomplished with the following
commands:

Show policy-map <policy-map-name>
Show class-map <class-map-name>
Show policy interface <interface>
Show interface <interface>



The Show Policy-map command displays the contents of a policy map, including the
priority setting in a specific policy map if one is included. It shows the classes that belong
to the priority queue along with what traffic belongs to the default-class. It should be
noted the default queue uses weighted-fair queuing. The example below shows 16 queues
in the WFQ.

umr# Show policy-map Video
Policy Map Video
class Video
Strict Priority
Bandwidth 1000 (kbps)
class class-default
Flow Based Fair Queueing
Number of Hashed Queues 16 Max Thresh 64 (packets)



Qos Implementation Guide on Cisco Routers Page 5
The Show class-map command shows the criteria for a packet to become a member of a
class. Currently, MOREnet uses ip precedence to determine the membership of the Video
class.

umr# Show class-map Video
Class Map match-any Video (id 2)
Match ip precedence 5

The Show policy interface command shows what class-maps are configured under a
policy-map applied to the named interface. You can determine if the desired QoS policy
is active on the interface, and how much of the traffic meets the requirements to become
a member of the class. It also tells how many packets have been dropped from the output
queue. If there are drops present it is because congestion was present in the circuit and
the queues started to drop packets to make way for the high priority traffic.

umr# show policy interface atm2/0

: VC 3/200

service-policy output: Video

class-map: Video (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
match: ip precedence 5
0 packets, 0 bytes
5 minute rate 0 bps
Strict Priority
Output Queue: Conversation 24
Bandwidth 1000 (kbps) Packets Matched 153573
(pkts discards/bytes discards) 314/196588

class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
match: any
0 packets, 0 bytes
5 minute rate 0 bps
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 Max Threshold 64 (packets)

The show interface command gives you the interface statistics, and it also gives you how
many output queue drops have occurred on the interface. This is a quick way to
determine if there has been congestion and if packets are being dropped. It also tells you
if the QoS commands are applied to the physical or logical interface. In this case, it is
applied to the logical because the queuing mechanism is for each virtual channel or VC.


Qos Implementation Guide on Cisco Routers Page 6

umr#show interface atm 2/0
ATM2/0 is up, line protocol is up
Hardware is ENHANCED ATM PA
Description: ATM Link to MOREnet
MTU 4470 bytes, sub MTU 4470, BW 40000 Kbit, DLY 190 usec,
reliability 255/255, txload 68/255, rxload 101/255
Encapsulation ATM, loopback not set
Keepalive not supported
Encapsulation(s): AAL5
4096 maximum active VCs, 4 current VCCs
VC idle disconnect time: 300 seconds
Signalling vc = 5, vpi = 2, vci = 5
UNI Version = 4.0, Link Side = user
66 carrier transitions
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters 11w0d
Input queue: 0/75/3169/489074 (size/max/drops/flushes); Total output drops: 1922977
Queueing strategy: Per VC Queueing
5 minute input rate 15881000 bits/sec, 3567 packets/sec
5 minute output rate 10703000 bits/sec, 3259 packets/sec
2098610064 packets input, 3049686719 bytes, 1 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
458 input errors, 458 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
1144017672 packets output, 1102453938 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

You might also like