You are on page 1of 7

Ejercicios Resueltos de Vectores y Matrices

1. La facultad de ingeniera desea llevar el control de su personal (estudiantes,


profesores, administrativos y obreros), en sus diferentes escuelas. Calcular

Reportar el total de personas en cada una de las escuelas


Imprimir el total de personas por cada una de las categoras
Imprimir el numero mayor y menor de personas, en que escuela se encuentra

y que categora de personal


Reportar el total de cada una de las categora de una escuela seleccionada
Reportar el total de estudiantes de todas las escuelas
Imprimir el total de personas que conforman la facultad de ingeniera
Respuesta

La Facultad de ingeniera esta constituida por 7 escuela; es decir que


la matriz que voy a formar puede ser 7 * 4 o 4 * 7; dependiendo del
programador; en este caso ser de 7 * 4; las escuelas sern filas y las
columnas el tipo de personal

Estudia
ntes
Escuel
a1
Escuel
a2
Escuel
a3
Escuel
a4
Escuel
a5
Escuel
a6
Escuel
a7

Profeso
res

Administr
ativo

Obrer
os

Inicio
Leer 7, 4 I=1, 7; J=1; 4; A(i,j)
Sf=0
Para i=1, 7
Para j=1, 4
Sf=sf + a(i,j)
Fin para
Escribir el total de la escuela , i, es, sf
Sf=0
Fin para
Sc=0
Para j=1, 4
Para i=1, 7
Sc=sc+a(i,j)
Fin para
Escribir el total de la categora, j,es, sc
Sc =0
Fin para
Ma=a(1,1)
Fma=1
Cma=1
Me=a(1,1)
Fme=1
Cme=1
Para i=1, 7
Para j=1, 4
Si (a(i,j)>ma) entonces
Ma= a(i,j)
Fma= i
Cma= j
Fin si
Si (a(i,j)<me) entonces
Me = a(i,j)
Fme=i
Cme=j
Fin si

Fin para
Fin para
Escribir el valor menor es:, me, categora,
cme, escuela ,fme
Escribir el valor mayor es:, ma, categora,
cma, escuela ,fma
Para reportar el personal de una categora
seleccionada por el usuario; en este caso
una columna especifica
1

Escribir seleccione la escuela a reportar


Leer N
Si (n <1 o N >7) entonces
Escribir error en el dato
Ir a 1
Fin si

Como ya tengo la columna especificada por el usuario,


solamente utilizo el ciclo repetitivo de columna

Para j=1, 4
Escribir el total de la categoria, j, de la escuela, n,
es , A(n,i)
Fin para

Se reportara el total de estudiante por cada escuela


; es decir la columna 1

Para i=1, 7
Escribir el total de estudiante de la escuela , i, es,
a(i,1)
Fin para

Escribir I=1, 7; j=1, 4; a(i,j)


Fin

2 El dueo de una tienda desea llevar el control de inasistencias semanales


(lunes-sbado) de sus empleados de las diferentes departamentos, se debe
implementar un programa que calcule:
o Imprimir
el total de inasistencias

por cada uno de los

departamentos
o Imprimir el total de inasistencias por cada uno de los das
o Reportar el da y el departamentos con mayor y menor numero de
inasistencias
o Imprimir el control de inasistencia de la tiendas (toda la matriz)
o Reportar el promedio de inasistencia de la semana de la tienda

En este caso se debe solicitar el numero de


departamentos, la matriz ser dpto./das o das/dptos,
de acuerdo al anlisis de cada uno

Inicio
Leer n, 6, i=1, n, j=1, 6; a(i,j)
Sf=0
Para i=1, n
Para j=1, 6
Sf=sf + a(i,j)

Fin para
Escribir el total de inasistencia del dpto, i, es,
sf
Sf=0
Fin para
Sc=0
Para j=1, 6
Para i=1, n
Sc=sc+a(i,j)
Fin para
Escribir el total de de las inasistencias del dia ,
j,es, sc
Sc =0
Fin para
Ma=a(1,1)
Fma=1
Cma=1
Me=a(1,1)
Fme=1
Cme=1
Para i=1, n
Para j=1, 6
Si (a(i,j)>ma) entonces

Ma= a(i,j)
Fma= i
Cma= j
Fin si
Si (a(i,j)<me) entonces
Me = a(i,j)
Fme=i
Cme=j
Fin si
Fin para
Fin para
Escribir el valor menor es:, me, dia, cme,
dpto ,fme
Escribir el valor mayor es:, ma, dia, cma,
dpto ,fma
Escribir I=1, n; j=1, 6; a(i,j)
S=0
Para i=1, n
Para j=1, 6
S=s+a(i,j)
Fin para
Fin para
P=s/(n*6)

Escribir el promedio es , p
Fin