You are on page 1of 13

Segunda parte

cout<<"notable"<<"\n";

Cdigo c++

else

1.//
#include <cstdlib>

cout<<"sobresaliente"<<"\n";

#include <iostream>

cout<<"desea ingresar mas


datos(s/n)?"<<endl;;

#include <conio.h>

cin>>op;

using namespace std;

}while(op=='s');

int main()

getch();

return 0;

float n;
char op;

do {

Pseudocdigo

cout<<"nota
alfabetica"<<endl;

Inicio

cout<<"ingrese una
nota:";cin>>n;

n: real

//variables

op: caracter

if(n<15)
if(n<11)
if(n<10.5)

Hacer
escribir "nota alfabetica"
Leer n

cout<<"insuficiente"<<"\n";
else

Si (n<15)
si (n<11)
si (n<10.5)

cout<<"suficiente"<<"\n";
else
cout<<"bien"<<"\n";
else
if(n<18)

escribir insuficiente"
sino
escribir "suficiente"
sino
escribir "bien"

sino

si(n<18)
escribir "notable
sino
escribir sobresaliente
escribir desea
ingresar mas
datos(s/n)?"
mientras(op='s');

{comision=0;
cout<<"comision por las ventas
realizadas: "<<comision<<"\n";
}
else
if(vr>200 && vr<=1000)
{comision=0.1*vr;
cout<<"comision por las
ventas realizadas
"<<comision<<"\n";

Fin

2.//

else

#include <cstdlib>

if(vr>1000 && vr<=2000)

#include <iostream>

{comision=0.15*vr;

#include <conio.h>
using namespace std;
int main()
{

cout<<"comision por las


ventas realizadas:
"<<comision<<"\n";
}
else

int vr;
float comision;

if(vr>2000 &&
vr<=3000)
{comision=0.2*vr;

char op;
do {
cout<<"ingresar el numero de
ventas:";

cout<<"comision por
las ventas realizadas:
"<<comision<<"\n";
}

cin>>vr;

else
if(vr>3000 &&
vr<=4000)
if(vr>=0 && vr<=200)

{comision=0.25*vr;

cout<<"comision
por las ventas realizadas:
"<<comision<<"\n";

op:caracter
Hacer
Leer vr

}
else
if(vr>4000 )

Si (vr>=0 y vr<=200)
comision=0
sino

{comision=0.3*vr;

si (vr>200 y vr<=1000)

cout<<"comision por las ventas


realizadas: "<<comision<<"\n";
}
else
cout<<"error"<<"\n";

comision=0.1*vr;
sino
si(vr>1000 y vr<=2000)
comision=0.15*vr

sino
si (vr>2000 y

cout<<"desea
ingresar mas datos(s/n)?"<<endl;;
cin>>op;

vr<=3000)
comision=0.2*vr
sino

}while(op=='s');
getch();
return 0;

si(vr>3000 &&
vr<=4000)
comision=0.25*vr

sino
si (vr>4000 )

Pseudocdigo
Inicio

comision=0.3*vr
sino

//variables

escribir "error"

vr:entero
commision:real

fin si
fin si

fin si

hb=2*sqrt(d)/b;

fin si

hc=2*sqrt(d)/c;

fin si
fin si
escribir comisin
escribir "desea ingresar mas
datos(s/n)?"
mientra (op='s');

cout<<"la altura relativa al lado


a es:"<<ha<<"\n";
cout<<"la altura relativa al lado
b es:"<<hb<<"\n";
cout<<"la altura relativa al lado
c es:"<<hc<<"\n";

Fin

}
else

3.//
#include <cstdlib>

cout<<"los lados no determinan


un triangulo";
getch();

#include <iostream>

return 0;

#include <conio.h>
#include <math.h>

using namespace std;


int main()

Pseudocdigo

Inicio

float a,b,c,area,ha,hb,hc,p,d;

//variables
cout<<"ingresar los lado del
triangulo:";
cin>>a>>b>>c;

a,b,c,area,ha,hb,hc,p,d: reales
leer a,b,c
p=(a+b+c)/2

p=(a+b+c)/2;

d=p*(p-a)*(p-b)*(p-c)

d=p*(p-a)*(p-b)*(p-c);

si (d>0)

if(d>0)

ha=2*(d)^0.5/a;

hb=2*(d)^0.5/b;

ha=2*sqrt(d)/a;

hc=2*(d)^0.5/c;

getch();
Escribir "la altura relativa al lado
a es:ha

}
int numdig(long int x)

Escribir "la altura relativa al lado b


es:hb
Escribir "la altura relativa al lado c
es:hc

{
int i=0;

sino

while(x>0)

escribir los lados no determinan


un triangulo"

Fin

i++;
x=x/10;

4.//
#include <cstdlib>
#include <iostream>
#include <conio.h>
#include <math.h>

}
return i;
}
Pseudocdigo
Inicio
//variables

using namespace std;


int numdig(long int x);

n: real
leer
escribir n tiene numdig(n)
digitos"

int main()
{

ent funcin numdig(x)


inicio

long int n;
cout<<"ingrese un numero
entero:";cin>>n;
cout<< n<<"tiene
"<<numdig(n)<<" digitos";
cout<<" pulsa cualquier tecla....";

i=0,x:entero
mientras (x>0)
i++;
x=x/10
fin mientras

retornar i

getch();

fin funcion
Fin

}
int menor(int x,int y, int z)
{
int min;
min=x;
if(y<min)

5.//

min=y;

#include <cstdlib>

if(z<min)

#include <iostream>

min=z;

#include <conio.h>
using namespace std;
int menor(int x,int y, int z);

return min;
}
Pseudocdigo

int main()

Inicio

//variables
int a,b,c;

cout<<"\nIngrese el primer
numero:";
cin>>a;
cout<<"\nIngrese el segundo
numero:";
cin>>b;
cout<<"\nIngrese el tercer
numero:";
cin>>c;

a,b,c: enteros
leer a,b,c
escribir el menor es: menor(a,b,c
)"

ent funcin menor (x,y,z)


inicio
min:ent
min=x
Si (y<min)

cout<<"\n\nEl numero menor


es:"<<menor(a,b,c)<<endl;

min=y
si (z<min)

min=z
retornar min;
fin funcion
fin

getch();
}
float longitud (float r1)
{
return 2*pi*r1;
}

Problemas sobre funciones

float area(float r2)

1.//

#include <cstdlib>

return pi*r2*r2;

#include <iostream>

#include <conio.h>

Pseudocdigo
Inicio

using namespace std;

//variables

float longitud(float r1);

r,s,l:reales

float area(float r2);

leer r

const float pi=3.1416;

l=longitud(r);

int main()

s=area(r);

escribir l,s

float r,s,l;
cout<<" Ingresar el radio de la
circunferencia:";
cin>>r;
l=longitud(r);
s=area(r);
cout<<" La longitud
es:"<<l<<endl;
cout<<" El area es:"<<s<<endl;

real funcin longitud (r1)


inicio
retornar 2*3.1416*r1
fin funcin
real funcin area (r2)
inicio
retornar 3.1416*r2*r2
fin funcin

Fin

importe=cantidad*precio;
switch(tipoCompra)

2.//

#include <cstdlib>

case '1':

#include <iostream>
#include <conio.h>

recargoIGV=calculoIGV(importe);
break;

using namespace std;

case '2':

float calculoIGV(float numero,float


IGV=0.18);
int main()

recargoIGV=calculoIGV(importe);
break;

case '3':

char tipoCompra;
int cantidad;
float
precio,importe,recargoIGV,tPagar;

recargoIGV=calculoIGV(importe,0.0)
;
break;
}

cout<<"\nSuministros A&C";
cout<<"\n.............\n\n";
cout<<"Cual de los siguientes
desea comprar";
cout<<"\n[1]Diskettes,[2]CDROM,[3]Libros";
cout<<"\nElija su
opcion:";cin>>tipoCompra;
cout<<"\nCantidad.....";cin>>cantid
ad;
cout<<"Precio....:";cin>>precio;
//calcula importe

//calculo del total a pagar


tPagar=importe+recargoIGV;
//salida de datos
cout<<"\n\nRecargo
IGV:"<<recargoIGV;
cout<<"\nEl total a pagar
es:"<<tPagar;
getch();
return 0;
}

float calculoIGV(float numero,float


IGV)
{

case '3':
recargoIGV=calculoIGV(importe,0.0)

return(numero*IGV);
}

saltar
fin segn sea

Pseudocdigo

tPagar=importe+recargoIGV;

Inicio

escribir Recargo IGV,tPagar

//variables

real calculoIGV( real:numero,


real:IGV)

tipoCompra: caracter
cantidad: entero

inicio
retornar numero*IGV

precio,importe,recargoIGV,tPagar:
real

fin funcin

escribir "Suministros A&C"

Fin

escribir "Cual de los siguientes


desea comprar"
escribir "\n[1]Diskettes,[2]CDROM,[3]Libros"
leer tipoCompra,cantidad,precio
importe=cantidad*precio;

3.//
#include <cstdlib>
#include <iostream>
#include <conio.h>
using namespace std;

segn sea (tipoCompra)


caso '1':

float volumen(float a);


int main()
{

recargoIGV=calculoIGV(importe)
saltar
case '2':
recargoIGV=calculoIGV(importe)
saltar

float lado,vol;
cout<<"El lado del cubo es:";
cin>>lado;
vol=volumen(lado);
cout<<"el volumen es:"<<vol;

getch();

long numero,resultado;

float volumen(float a)

cout<<"\nIngrese un numero:";

cin>>numero;
return a*a*a;

resultado=fibonacci(numero);

}
Pseudocdigo

cout<<"\nFibonacci("<<numero<<"
):"<<resultado;

Inicio

getch();

//variables

return 0;

Lado,vol:reales
leer lado
vol=volumen(lado);

}
long fibonacci(long n)
{

escribir vol
real funcin volumen (real a)

if(n==0 || n==1)

inicio

return n;

retornar a*a*a
fin funcin
Fin

else
return fibonacci(n-1)+
fibonacci(n-2);
}

4.//

Pseudocdigo

#include <cstdlib>

Inicio

#include <iostream>

//variables

#include <conio.h>

numero,resultado:reales

using namespace std;

leer numero

long fibonacci(long n);


int main()

resultado=fibonacci(numero);
escribir resultado
real funcin fibonacci(real n)

inicio
si (n==0 n==1)
retornar n
sino
retornar fibonacci(n-1)+
fibonacci(n-2)
fin si
fin funcin
Fin

getch();
}
int factorial(int num)
{
if(num==0)
return 1;
else
return num*factorial(num-1);
}

Pseudocdigo
5.//
#include <cstdlib>
#include <iostream>
#include <conio.h>
using namespace std;

Inicio
//variables
i:entero
para(i=1,i<=10,i++)

int factorial(int num);

escribir el factorial de: i es


:factorial

int main()

int funcin factorial(entero:num)

inicio
int i;
for(i=1;i<=10;i++)
{

cout<<"el factorial de "<<i<<"


es:"<<factorial(i)<<endl;
}

Si (num==0)
retornar1
sino
retornar num*factorial(num-1)
fin si
fin funcin

Fin