You are on page 1of 5

RESUMEN DE COMANDOS CCNA EXPLORATION

CONFIGURACION BASICA:
R1#set clock <hh:mm:dd> <month> <year>
R1(config)#hostname
R1(config)#no ip domain-lookup
R1(config)#enable secret <contrasea>
R1(config)#service password-encryption
R1(config)#banner motd #This is the Boston R1.Authorized Access Only#
R1(config)#clock timezone <name> <hours UTC>
R1(config)#line console 0
R1(config-line)#password <0 | 7 | line>
R1(config-line)#login <login | tacacs | cr>
R1(config-line)#logging synchronous
R1(config-line)#exec-timeout <min> <seg>
R1(config)#line vty 0 4
R1(config-line)#password <0 | 7 | line>
R1(config-line)#login <login | tacacs | cr>
R1(config-line)#logging synchronous
R1(config-line)#exec-timeout <min> <seg>

CONFIGURACION BASICA DE INTERFAZ:


R1(config)#interface <tipo de interfaz> <Puerto de interfaz>
R1(config-if)# ip address <direccin ip> <mascara de subred>
R1(config-if)# no shutdown
R1(config-if)# clock rate <numero> => OPCIONAL SOLO SERIALES
R1(config-if)# duplex <full|half>
R1(config-if)# speed <10|100|1000>
R1(config-if)# bandwitch <numero en kbps>

RUTA ESTATICA Y POR DEFECTO:


R1(config)#Ip route <Network> <Mask> <Interface | Next hop>
R1(config)#Ip route 0.0.0.0 0.0.0.0 <Interface | Next hop>

PROTOCOLO DE ENRUTAMIENTO RIP:


R1(config)#R1 rip
R1(config-Router)#network <network>
R1(config-Router)#default-information originate
R1(config-Router)#redistribute static
R1(config-Router)#passive-interface <interface>
R1(config-Router)#version <1 | 2>
R1(config-Router)#no auto-summary
R1(config-Router)#timers basic <invalid> <hold down> <flush> <sleep time>

R1(config-Router)#maximum-paths <number of paths>


R1(config-Router)#ip split-horizon
R1(config-if)# ip summary-address eigrp <as-number> <network> <mask>
R1(config-if)#ip rip <send | receive> version <1 | 2>
R1(config)#key chain <name>
R1(config-keychain)#key <key identifier>
R1(config-keychain-key)#key-string <0 | 7 | line>
R1(config-keychain-key)#accept-lifetime <start-time> <infinite | end-time | duration>
R1(config-keychain-key)#send-lifetime <start-time> <infinite | end-time | duration>
R1(config-if)#ip rip authentication key-chain <name-of-chain>
R1(config-if)#ip rip authentication mode <text | md5>

PROTOCOLO DE ENRUTAMIENTO EIGRP:


R1(config)#R1 eigrp <AS>
R1(config-Router)#network <network> <wildcard | cr>
R1(config-Router)#redistribute static
R1(config-Router)#passive-interface <interface>
R1(config-Router)#default-metric <bandwith> <delay> <realibility> <load> <mtu>
R1(config-Router)#no auto-summary
R1(config-Router)#maximum-paths <number of paths>
R1(config-Router)#variance <metric variance multiplier>
R1(config-Router)#metric weight <ToS> <k1> <k2> <k3> <k4> <k5>
R1(config-Router)#neighbor <ip address> <interface out>
R1(config-if)#ip summary-address eigrp <as-number> <network> <mask>
R1(config)#key chain <name>
R1(config-keychain)#key <key identifier>
R1(config-keychain-key)#key-string <0 | 7 | line>
R1(config-keychain-key)#accept-lifetime <start-time> <infinite | end-time | duration>
R1(config-keychain-key)#send-lifetime <start-time> <infinite | end-time | duration>
R1(config-if)#ip rip authentication key-chain eigrp <as> <name-of-chain>
R1(config-if)#ip rip authentication mode eigrp <text | md5>

PROTOCOLO DE ENRUTAMIENTO OSPF:


R1(config)#R1 ospf <ID proceso>
R1(config-Router)#network <network> <wildcard> area <number>
R1(config-Router)#default-information originate
R1(config-Router)#
R1(config-Router)#
R1(config-Router)#passive-interface <interface>
R1(config-Router)#area <area-id> range <address> <mask> => configurar en ABR
R1(config-Router)#summary-address <address> <mask> => configurar en ASBR
R1(config-if)#ip ospf authentication-key <password>
R1(config-if)#ip ospf authentication <message-digest | null>

R1(config-Router)#area <area-id> authentication <message-digest>


R1(config-if)#ip ospf message-digest-key <key-id> md5 <key>
R1(config-if)#ip ospf authentication <message-digest>

FRAME RELAY:
R1(config)#interface <subinterface> point-to-point
R1(config)#interface <subinterface> multipoint
R1(config-if)#encapsulation frame-relay <ietf | mfr>
R1(config-if)#frame-relay intf-type <dce | dte | nni>
R1(config-if)#frame-relay lmi type <ansi | cisco | q933a>
R1(config-if)#frame-relay interface-dlci <dlci number>
R1(config-if)#frame-relay map ip <IP remote> <DLCI local> broadcast
R1(config-if)#no frame-relay inverse arp
FR(config)#frame-relay switching
FR(config-if)#no ip address
FR(config-if)#encapsulation frame-relay
FR(config-if)#frame-relay intf-type <dce | dte | nni>
FR(config-if)#clock rate 64000
FR(config-if)#frame-relay route <input DLCI> interface <interface out> <DLCI output>
Resolucin de problemas:
R1#show frame-relay map
R1#show frame-relay pvc
R1#show frame-relay lmi
R1#clear frame-relay counters
R1#clear frame-relay inarp
R1#debug frame-relay lmi

TROUBLESHOOTING:
R1#show running-config
R1#show ip route
R1#show ip interface brief
R1#show ip protocols
R1#debug ip rip

NAT:
R1(config)#ip nat inside source static <inside local address> <inside global address>
R1(config-if)#ip nat inside
R1(config-if)#ip nat outside
R1(config)#ip nat pool <name> <range inside global address> netmask <mask>
R1(config)#access-list <number> permit <source network> <wildcard>
R1(config)#ip nat inside source list <nacl> pool <pool name>
R1(config-if)#ip nat inside
R1(config-if)#ip nat outside
R1(config)#access-list <number> permit <source network> <wildcard>
R1(config)#ip nat inside source list <nacl> interface <outside interface> overload
R1(config-if)#ip nat inside

R1(config-if)#ip nat outside


R1(config)#ip nat pool <name> <range inside global address>
R1(config)#access-list <number> permit <source network> <wildcard>
R1(config)#ip nat inside source list <nacl> pool <pool name> overload
R1(config-if)#ip nat inside
R1(config-if)#ip nat outside
R1(config)#ip nat inside source static <tcp/udp> <IPLocalInterna> <Puerto>
<IPGlobalInterna> <Puerto>
Resolucin de problemas:
R1#show ip nat translations
R1#show ip nat statistics
R1#debug ip nat
R1#clear ip nat translations *

PROTOCOLO PUNTO A PUNTO PPP:


R1(config)#hostname <name>
R1(config)#username <name> password <password>
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication <pap | chap | chap pap | pap chap>
R1(config-if)#ppp pap sent-username <username remote> password <password>
R1(config-if)#ppp quality <percentage>
R1(config-if)#ppp multilink
Resolucin de problemas:
R1#show interfaces <type> <port>
R1#show controllers
R1#debug ppp <packet | negotiation | error | authentication | compression>.

DHCP:
R1(config)#service dhcp
R1(config)#ip dhcp pool <nombre-pool>
R1(config-dhcp)#network <network> <mask>
R1(config-dhcp)#default-router <hostname | ip address>
R1(config-dhcp)#dns-server <hostname | ip address>
R1(config-dhcp)#netbios-name-server <hostname | ip address>
R1(config-dhcp)#domain-name <domain>
R1(config-dhcp)#lease <days | infinite>
R1(config-dhcp)#option <DHCP option code>
R1(config-dhcp)#relay <destination | source>
R1(config-if)#ip address dhcp
Resolucin de problemas:
R1#show ip dhcp server statistics
R1#show ip dhcp <binding | conflict | database | import | pool | relay>
R1#debug ip dhcp server <class | events| linkage | packet>

ACESS-LIST:
R1(config)#access-list <1-99 | 1300-1999> <permit | deny | remark > <ip address | any |
host> <wilcard>
R1(config)#access-list <100-199 | 2000-2699> <permit | deny | dynamic | remark>
<protocol> <ip source | any | host> <wilcard> <ip destination | any | host> <wilcard>
R1(config)#Ip access-list <standard> <1-99 | 1300-1999> <name>
R1(config)#Ip access-list <extended> <100-199 | 2000-2699> <name>

You might also like