You are on page 1of 3

3 Steps internally

- Find the outgoing interface, routing table, routing information base (RIB), fo
rwarding information table (cef/fib)
- move the packet between interfaces
- build the layer 2 header (Layer 3 Routing rebuilt layer 2 information from hop
by hop basic)
IP over Ethernet (used ARP)
IP over NBMA (Frame Relay) static framelay mapping - point to point mapp
ing (PPP or HDLC)
Routing Process
1. lookup routing table and find the longest match of the destination address
- independent of the AD or Matrix
2 What is the next hop value associate and lookup outgoing interface
3 Hands off to switching process
Metric Vs Distance
- Same protocol with multiple longest matches, use lowest metric
- Different Protocol, use lowest AD
- Connected
0
- Static
1
- EIGRP(Summary)
5
- EBGP
20
- EIGRP(Inter) 90
- OSPF
110
- RIP
120
- RIGRP(EX)
170
- iBGP
200
Switching Process
- Process, Fast, CEF
- Any transit traffic sent to the CEF process by default
Route to next hop
- Recurse to the interface, lookup until to figure out outgoing interface
BGP
- allows you to create loop free interdomain routing between autonomous systems
- use TCP 179
- BGP peer initially exchange full routing table
- incremental updates are sent as the routing table changes
- keep alive packets are sent to ensure that the connection is alive between BGP
peers
- notification packets are sent in response to erros and special conditions
- iBGP use same AS and eBGP use different AS
- eBGP peers are directly connected and iBGP peers are not
- BGP will not accept updates that have originated from its own AS. This is to i
nsure a loop free interdomain topology.
- the next hop advertised by EBGP should be carried into IBGP.
sh ip bgp neighbor
- route map cannot be applied on the inbound when matching based on the IP addre
ss.
int loopback 0
ip addr 160.10.1.1 255.255.255.0
router bgp 200

neighbor 150.10.1.1 remote-as 100


neighbor 150.10.1.1 update-source loopback 0
interface
neighbor 150.10.1.1 ebgp-multihop
y connected interface
network 160.10.0.0
o neighbor

: BGP update send using loopback


: eBGP peer is not using directl
: advertise loopback interface t

ip route 150.10.0.0 255.255.0.0 1.1.1.1 : must have IGP route (IP connectivity)
to 150.10.1.1 interface
ip route 150.10.0.0 255.255.0.0 2.2.2.1
The related commands for match are:
match as-path
match community
match clns
match interface
match ip address
match ip next-hop
match ip route-source
match metric
match route-type
match tag
The
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set

related commands for set are:


as-path
automatic-tag
community
clns
interface
default interface
ip next-hop
ip default next-hop
ip precedence
tos
level
local-preference
metric
metric-type
next-hop
origin
tag
weight

different methods to originate routes out of our autonomous system


neighbor 2.2.2.2 route-map STOPUPDATES out
: using route-map to fil
ter route advertisement. route map with match ip can only apply outbound.
route-map STOPUPDATES permit 10
match ip address 1
access-list 1 deny 170.10.0.0 0.0.255.255
access-list 1 permit 0.0.0.0 255.255.255.255
neighbor 1.1.1.1 distribute-list 1 out
to filter route advertisement
access-list 1 permit 175.220.0.0 0.0.255.255
neighbor 1.1.1.1 remote-as 300
nto BGP for route advertisement
redistribute static

: using distribute-list

: using static to redistribute i

ip route 175.220.0.0 255.255.255.0 null0


BGP Attributes
AS Path : list of AS numbers that a route has traversed in order to reach a dest
ination
Origin : i (IBGP), e (EBGP), ? (incomplete)
Next Hop
: next hop (NBMA) use next-hope-self to force BGP to use specifi
ed IP address as the next hop rather than letting the protocol choose the next h
op
neighbor 170.10.20.1 next-hop-self
BGP backdoor will make the IGP route, the preferred route

You might also like