You are on page 1of 8

CertificationZone Page 1 of 8

Date of Issue: 02-01-2000

Voice over IP/Frame Relay Lab Scenarios


by Chris Ackerman

Lab Scenario 1 - Voice over IP


Objective
Configuration of Router A
Configuration of Router B
Explanation of Router Commands

Lab Scenario 2 - Voice over Frame-Relay


Objective
Configuration of Router A
Configuration of Router B
Explanation of Router Commands

Lab Scenario 1 - Voice over IP


Objective
Your organization wants to call from one location to another via your private leased line, which is passing only IP
traffic. Because of this, you decide that a VoIP solution is the best way to do go about providing communication
between the two offices.

As Network Administrator, you note that each site is using a Cisco 2610. You also find that there is room to put an
FXS port on each of them. To make calling easy for the users, create a simple dialing plan. For the phone attached to
Router A, dial 1001, and for the phone attached to Router B, dial 1002.

Figure 1. Voice Over IP Lab

Note that the WAN must be able to support traffic from the two Ethernet segments and provide quality voice service.

http://www.certificationzone.com/studyguides.../?Issue=27&IssueDate=02-01-2000&CP= 11/06/01
CertificationZone Page 2 of 8

Configuration of Router A
Building configuration...

Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_A
enable secret 5 $1$IM1E$54nbR7ceGJQHXdqCBMoTU.
!
ip subnet-zero
no ip domain-lookup
!
dial-peer voice 101 voip
destination-pattern 1002
ip precedence 5
session target ipv4:172.16.16.2
!
dial-peer voice 201 pots
destination-pattern 1001
port 1/0/0
!
voice-port 1/0/0
vad
!
voice-port 1/0/1
vad
!
interface Ethernet0/0
ip address 172.16.17.1 255.255.255.0
!
interface Serial0/0
ip address 172.16.16.1 255.255.255.252
!
ip classless
!
router eigrp 1
network 172.16.0.0
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

Configuration of Router B
Building configuration...

Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
enable secret 5 $1$IM1E$54nbR7ceGJQHXdqCBMoTU.
!
ip subnet-zero
no ip domain-lookup
!
dial-peer voice 101 voip
destination-pattern 1001

http://www.certificationzone.com/studyguides.../?Issue=27&IssueDate=02-01-2000&CP= 11/06/01
CertificationZone Page 3 of 8

ip precedence 5
session target ipv4:172.16.16.1
!
dial-peer voice 201 pots
destination-pattern 1002
port 1/0/0
!
voice-port 1/0/0
timeouts call-disconnect 0
!
voice-port 1/0/1
timeouts call-disconnect 0
!
interface Ethernet0/0
ip address 172.16.18.1 255.255.255.0
!
interface Serial0/0
ip address 172.16.16.2 255.255.255.252
!
ip classless
!
router eigrp 1
network 172.16.0.0
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

Explanation of Router Commands


Since both routers have similar configurations we will only look at Router A.

Dial Peer statements are used to configure phone call routing. There are two basic dial peer statements: 1) ones that
point to local voice ports, Dial-peer Pots, and 2) the ones that point to a remote system, Dial-peer VoIP.

Each peer can be configured to respond in a unique way. For example, the dial-peer statement can place priority on
the call packets. This can be configured by placing a higher IP precedence on the packets destined for the dial-peer
VoIP remote IP address. VoIP packets with a precedence of 5 are given higher priority than packets from the Ethernet
segments.

dial-peer voice 101 voip


destination-pattern 1002
ip precedence 5
session target ipv4:172.16.16.2

dial-peer voice 201 pots


destination-pattern 1001
port 1/0/0

A voice port is a special type of router interface that accepts voice data from outside sources. Voice ports can be
configured to take advantage of Voice Activated Detection (VAD).

voice-port 1/0/0
vad
!
voice-port 1/0/1
vad

Lab Scenario 2 - Voice over Frame-Relay


Objective
As the CIO, you want to reduce the costs of your long distance phone bills. After doing some research you find that

http://www.certificationzone.com/studyguides.../?Issue=27&IssueDate=02-01-2000&CP= 11/06/01
CertificationZone Page 4 of 8

the bulk of the long distance calls are made to the remote office. If these costs could be curtailed, the phone bill would
be reduced by 60%.

Already existing is a Frame-Relay network between the two sites with a CIR of 768 Kbps. Although the company
needs this network to do business, you find that the traffic between the sites is a bit lower than the CIR even at peak.
You have heard that Voice over IP is not as efficient as Voice over a Layer 2 protocol, so you decide to take
advantage of your already existing Frame-Relay network to transport voice.

Figure 1. Voice Over Frame-Relay Setup

For employee satisfaction, you have decided that you want no calls to be blocked. Call traffic analysis has revealed
that there are typically no more than four simultaneous calls between the offices.

Build a Frame-Relay network using Cisco 3810 multi-service routers at each site. You will need to connect the routes
to the local PBXs and direct traffic destined for the remote site to the 3810s. The 3810 routers will receive voice from
the PBX, encode it using G.729a, and send to the remote 3810.

A caller will dial 8 to access the 3810s before dialing the four digit extension of the remote office called party. Any
four-digit number starting with 4 will be sent to the remote site and any four-digit number starting with 2 will be sent to
corporate.

Each of the 3810 routers has an Ethernet interface running IP. IP traffic between the two routers will need to be
transported as well.

Configuration of Router A
!
Version 11.3
No service pad
No service password-encryption
!
hostname Router_A
!

!
network-clock base-rate 64k
no ip domain-lookup
!
!
controller T1 0
framing esf

http://www.certificationzone.com/studyguides.../?Issue=27&IssueDate=02-01-2000&CP= 11/06/01
CertificationZone Page 5 of 8

linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
controller T1 1
framing esf
clock source internal
linecode b8zs
mode cas
voice-group 1 timeslots 1-4 type e&m-wink-start
!
interface Ethernet0
ip address 172.16.17.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Serial2
no ip address
encapsulation frame-relay
frame-relay traffic-shaping
hold-queue 1024 out
!
interface Serial2.1 point-to-point
ip address 172.16.16.1 255.255.255.252
frame-relay interface-dlci 102 voice-encap 80 class-FR1
!
router eigrp 100
network 172.16.0.0
!
ip classless
!
map-class frame-relay FR1
no frame-relay adaptive-shaping
frame-relay cir 768000
frame-relay bc 1000
!
!
!
line con 0
line aux 0
line vty 0 4
password Cisco
login
!
!
voice-port 1/1
!
voice-port 1/2
!
voice-port 1/3
!
voice-port 1/4
!
dial-peer voice 20 vofr
destination-pattern 4...
session target serial0 102
!
dial-peer voice 30 pots
destination-pattern 2...
port 1/1
!
dial-peer voice 30 pots
destination-pattern 2...
port 1/2
!
dial-peer voice 30 pots
destination-pattern 2...
port 1/3
!

http://www.certificationzone.com/studyguides.../?Issue=27&IssueDate=02-01-2000&CP= 11/06/01
CertificationZone Page 6 of 8

dial-peer voice 30 pots


destination-pattern 2...
port 1/4
!
!
end

Configuration of Router B
!
Version 11.3
No service pad
No service password-encryption
!
hostname Router_B
!

!
network-clock base-rate 64k
no ip domain-lookup
!
!
controller T1 0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
controller T1 1
framing esf
clock source internal
linecode b8zs
mode cas
voice-group 1 timeslots 1-4 type e&m-wink-start
!
interface Ethernet0
ip address 172.16.18.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Serial2
no ip address
encapsulation frame-relay
frame-relay traffic-shaping
hold-queue 1024 out
!
interface Serial2.1 point-to-point
ip address 172.16.16.2 255.255.255.252
frame-relay interface-dlci 201 voice-encap 80 class-FR1
!
router eigrp 100
network 172.16.0.0
!
ip classless
!
map-class frame-relay FR1
no frame-relay adaptive-shaping
frame-relay cir 768000
frame-relay bc 1000
!
!
!
line con 0
line aux 0
line vty 0 4
password Cisco
login
!
!

http://www.certificationzone.com/studyguides.../?Issue=27&IssueDate=02-01-2000&CP= 11/06/01
CertificationZone Page 7 of 8

voice-port 1/1
!
voice-port 1/2
!
voice-port 1/3
!
voice-port 1/4
!
dial-peer voice 20 vofr
destination-pattern 2...
session target serial0 201
!
dial-peer voice 30 pots
destination-pattern 4...
port 1/1
!
dial-peer voice 30 pots
destination-pattern 4...
port 1/2
!
dial-peer voice 30 pots
destination-pattern 4...
port 1/3
!
dial-peer voice 30 pots
destination-pattern 4...
port 1/4
!
!
end

Explanation of Router Commands


In this lab both of the routers are configured similarly. Each has one T1 CAS connection to the local PBX and a
Frame-Relay connection to the remote router. Since this is true, only Router A will be examined.

First, the channel rates must be set. 64 Kbps is used in this example.

network-clock base-rate 64k

The T-1 controller connecting to the PBX was set for CAS (Channel Associated Signaling). Notice that the
configuration line "voice-group" was used instead of channel-group. Only four channels are used in this configuration
because only four lines will ever be needed.

controller T1 1
framing esf
clock source internal
linecode b8zs
mode cas
voice-group 1 timeslots 1-4 type e&m-wink-start

Frame-Relay Traffic shaping commands must be configured on the serial port

interface Serial2.1 point-to-point


ip address 172.16.16.1 255.255.255.252
frame-relay interface-dlci 102 voice-encap 80 class-FR1

map-class frame-relay FR1


no frame-relay adaptive-shaping
frame-relay cir 768000
frame-relay bc 1000

Voice ports are created based on the number of timeslots configured on the T-1 controller.

voice-port 1/1

The dial plan must be configured to direct calls to the correct destination. VoFR dial-peers direct traffic to a remote
frame-relay router. Pots dial-peers direct calls to a specific port on the local router.

http://www.certificationzone.com/studyguides.../?Issue=27&IssueDate=02-01-2000&CP= 11/06/01
CertificationZone Page 8 of 8

dial-peer voice 20 vofr


destination-pattern 4...
session target serial0 102
!
dial-peer voice 30 pots
destination-pattern 2...
port 1/1

[IE-Mult-LS-F02]
[2000-01-31-01]
Copyright © 2000 Genium Publishing Corporation

http://www.certificationzone.com/studyguides.../?Issue=27&IssueDate=02-01-2000&CP= 11/06/01

You might also like