You are on page 1of 11

LAB 01 Configurando o R1

==== Objetivo do Laboratrio ====


Realizar as configuraes bsicas no roteador, a fim de conhecer melhor os modos de
configurao e se familiarizar com a linha de comando.
==== 1 Passo ====
Como primeiro passo devemos apagar quaisquer configuraes que estejam no equipamento,
feitas nos testes anteriores. Caso o roteador esteja pr-configurado com a senha de enable,
tente netts.
R1>enable
Password:
R1#

Estando no modo enable digite o comando erase startup-config. Este comando apaga as
configuraes salvas na nvram. Aps isso o roteador vai continuar funcionando normalmente,
pois as configuraes existentes esto salvas tambm na memria NRAM.
R1#erase startupconfig
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
R1#

Confirme o comando pressionado ENTER e digite reload. Este comando vai instruir o roteador
para que reinicie e retorne com as configuraes de fbrica.
R1#reload
Proceed with reload? [confirm]

*Jan 11 09:28:47.874: %SYS-5-RELOAD: Reload requested by console. Reload Reason:


Reload
Command.
Aps o reload completo, o roteador estar com suas configuraes padres.
==== 2 Passo ====
Quando todas as mensagens do processo de reinicializao do roteador estiverem passado,
pressione ENTER que voc ir direto para o modo user (modo de usurio), como abaixo: (Caso
no tenha aparecido a mensagem, aperte ENTER).
R1>

Digite enable e prossiga para o segundo modo que se chama exec (modo enable, modo
privilegiado).
R1>enable

R1#

Agora estando no modo de privilgio, onde poder tanto verificar como alterar configuraes,
voc pode tambm voltar ao modo de usurio (user mode) digitando o comando disable.
R1#disable
R1>

No prompt de comando, digite show version. Este comando muito utilizado para verificar o
tipode equipamento, verso de software, tamanho de memria, interfaces e etc.
R1#show version
Cisco IOS Software, Linux Software (I86BI_LINUXADVENTERPRISEK9M), Version
15.2(2.3)T,
ENGINEERING WEEKLY BUILD, synced to V151_4_M1_13
Copyright (c) 19862011 by Cisco Systems, Inc.
Compiled Thu 13Oct11 01:08 by hlo

ROM: Bootstrap program is Linux


R1 uptime is 3 minutes
System returned to ROM by reload at 0
System image file is unix:./images/i86bi_linux-adventerprisek9-ms
Last reload reason: Unknown reason
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to
export@cisco.com.
Linux Unix (Intel-x86) processor with 128906K bytes of memory.
Processor board ID 1
4 Ethernet interfaces
4 Serial interfaces
256K bytes of NVRAM.
Configuration register is 0x0
R1#
Examinando o resultado do comando acima, responda as seguintes questes abaixo em seu
caderno de anotaes, de acordo com o resultado que voc obteve na tela de seu terminal:
Qual a verso do Cisco IOS que este roteador est utilizando? Utilize o exemplo acima para
melhor se posicionar quanto a resposta.
__________________________________________________

Quantas interfaces Seriais esto disponveis neste equipamento?


__________________________________________________
Quantas interfaces Ethernet esto disponveis neste equipamento?
__________________________________________________
Qual o tamanho da memria NVRAM?
__________________________________________________
==== 3 Passo ====
de extrema importncia que o roteador tenha seu relgio configurado de forma correta e
precisa. A razo que no caso de uma anlise de falhas, os logs de erros e eventos constam o
horrio em que tudo aconteceu.
Em ambientes de DataCenter, fica praticamente impossvel configurar todos os roteadores e
switches com a mesma hora, minuto, segundo e milisegundo. Por isso sempre utilizamos um
servidor de NTP (Network Time Protocol). Dessa forma devemos apontar todos os dispositivos
de rede para o mesmo NTP Server afim de que todos se sincronizarem e se auto-configurem
para a hora atual.
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ntp server 129.67.1.160
R1(config)#end
R1#

O IP 129.67.1.160 um servidor de NTP Pblico da Web que vrios clientes utilizam para
sincronizar seus equipamentos de rede e servidores. Esse servidor tem redundncia e fica
99.9% do tempo em estado UP, se tornando uma tima opo para apontamento.
==== 4 Passo ====
Configurar o banner uma forma de apresentar na linha de comando, informaes e restries
ao seu ambiente de rede. Para configurar, utilize o comando banner motd a partir do como de
configurao, como mostramos abaixo:
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#no service config
R1(config)#banner motd #
===========================================================================
==
== NETTS TRAINING BRASIL
==
== YOU HAVE SUCCESSFULLY ENTERED THIS SYSTEM R1.
== BE ADVISED YOUR ACTIONS ARE LOGGED AND AUDITS ARE
== PERFORMED DAILY. IF YOU HAVE ANY QUESTION CONTACT THE
== SYSTEM ADMINISTRATOR.
==
==
== YOU ARE AT R1 ==
==
==
===========================================================================

Obs. Pressione enter para descer de linha quando estiver escrevendo o banner.
No comando acima, utilizamos o # para delimitar o inicio e fim do banner.
Caso queira verificar como ficou o banner, faa o logout e pressione ENTER
R1(config)#end
R1#

==== 5 Passo ====


Definir uma descrio as interfaces do roteador uma forma adotada para auxiliar no
gerenciamento da rede.
Logo abaixo, segue o comando para inserir uma descrio na interface Ethernet 0/0 do
roteador
R1. Como este equipamento est conectado ao Switch na porta Ethernet 0/0, vamos deixar
uma descrio bem clara disso.
Nota: Existem diversos modelos de roteadores Cisco em nosso DataCenter, por isso o nome
das interfaces pode ser diferente do que estamos demonstrando logo abaixo. Para identificar
qual o nome das interfaces do seu equipamento, digite o comando Show ip interface brief e
verifique o nome da interface Ethernet do router.
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface ethernet 0/0
R1(configif)#description === Conectado ao SW1 ===
R1(configif)#end
R1#

==== 6 Passo ====


So 5 os passwords que podemos configurar no roteador para garantir maior segurana. O que
iremos configurar agora o enable secret, pois sabemos que este tem precedncia ao antigo
enable password. O enable secret o password utilizado para restringir os acessos ao modo
de enable (modo de privilgio), limitando assim qualquer tipo de ataque a linha de comando.
Configure o password para nets
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#enable secret netts
R1(config)#end
R1#

==== 7 Passo ====


Na maioria das vezes quando voc precisa configurar um roteador logo pensamos no cabo
console. Mas na vida real o mais comum acessar remotamente o equipamento utilizando o
protocolo Telnet. Os roteadores e switches da Cisco possuem portas virtuais de acesso
chamadas VTY. Essas portas, por serem virtuais so mais de uma e precisam de um username
e password para que seja limitado o acesso via telnet.

A configurao simples e utilizamos os seguintes comandos:


R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#username netts password netts

Logo aps a criao do usurio senha, basta aplicar nas linhas de telnet.
R1(config)#line vty 0 4
R1(configline)#login local
R1(configline)#end
R1#

Como configurado acima, agora as linhas virtuais de acesso telnet que inicia na linha 0 e vai
at a 4 (somando 5 linhas virtuais no total), esto protegidas por usurio e senha.
==== 8 Passo ====
No podemos nos esquecer de que quando conectado o cabo console a porta console de
qualquer roteador, o usurio consegue acesso ao modo de usurio. Neste modo, possvel
retirar informaes valiosas para um possvel ataque ou maior conhecimento da topologia da
rede.
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#line console 0

Vamos agora conhecer outros comandos teis


O comando logo abaixo previne que mensagens apaream na tela sobrescrevendo o seu
comando. Ento as mensagens sempre iro aparecer na linha acima do que voc esta
digitando no momento.
R1(configline)#logging synchronous

O seguinte comando quando aplicado na linha console finaliza sua sesso caso no digite
nada pelo tempo de 10 minutos (por default), o primeiro zero indica minutos e o segundo zero
indica segundos, colocando o 0 0, voc desabilita o logout automtico. Mas o recomendado
voc definir um tempo para isso, por exemplo trs minutos ento o comando ficaria: exectimeout 3 0, ou trs minutos e trinta segundos, ento o comando ficaria: exec-timeout 3 30. Use
da forma que voc pensa ser a melhor para a sua necessidade.
R1(configline)#exectimeout 0 0
R1(configline)#end

==== 9 Passo ====


Para uma melhor identificao do equipamento, podemos alterar o nome do roteador. O
comando para alterar o hostname e deve ser executado do modo de configurao. Varias
empresas utilizam o hostname do equipamento para melhor identificar sua localizao, funo
e posio na topologia.
Exemplo:

O Roteador R1 esta no DataCenter de Londres na Inglaterra, no bairro de Southwark, no


segundoandar. Com essas informaes podemos criar um hotname da seguinte forma:
GBLOSWK_2F_R1_CR_1841#
Traduzindo
GB = Great Britain
LO = London
SWK = Southwark
2F = Second Floor
R1 = Rack 1
CR = Core Router
1841= Modelo do Roteador
Neste primeiro laboratrio no vamos alterar o hostname dos roteadores.
==== 10 Passo ====
Aps todos esses comandos de configurao, vamos analisar tudo que foi feito a partir do show
running-config.
R1#show runningconfig
Building configuration...

Current configuration : 1473 bytes


!
! Last configuration change at 12:49:22 UTC Tue Dec 10 2013
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$Ew51$Pc/IMHA6cDQ8/cx4BW8fQ1
!
no aaa new-model
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip auth-proxy max-login-attempts 5
ip admission max-login-attempts 5
!
!
!
no ip domain lookup

ip cef
no ipv6 traffic interface-statistics
no ipv6 cef
!
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
!
username netts password 0 netts
!
redundancy
!
!
!
interface Ethernet0/0
description === Conectado ao SW1 ===
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3

no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login local
transport input all
!
ntp server 129.67.1.160
!
End
Pressione a barra de espao algumas vezes para que todas as informaes sejam mostradas.
Analisando essa tela, voc pode verificar a verso de IOS, o nome do roteador, a descrio nas
interfaces e principalmente os passwords. O enable secret utiliza uma encriptao de dados
chamada de MD5, porm os passwords das linhas console e VTY esto visveis. Para corrigir
esse problema, vamos habilitar o servio de encriptao neste roteador.
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#service passwordencryption
R1(config)#end
R1#

Agora, verifique novamente o show running-config e verifique que os passwords esto


encriptados.
R1#show runningconfig
Building configuration...

Current configuration : 1477 bytes


!
! Last configuration change at 13:24:48 UTC Tue Dec 10 2013
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!

hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$Ew51$Pc/IMHA6cDQ8/cx4BW8fQ1
!
no aaa new-model
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip auth-proxy max-login-attempts 5
ip admission max-login-attempts 5
!
!
!
no ip domain lookup
ip cef
no ipv6 traffic interface-statistics
no ipv6 cef
!!
multilink bundle-name authenticated
!
!
!
crypto pki token default removal timeout 0
!
!
username netts password 7 04550E121B32
!
redundancy
!
!
!
interface Ethernet0/0
description === Conectado ao SW1 ===
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3

no ip address
shutdown
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login local
transport input all
!
ntp server 129.67.1.160
!
End

==== 11 Passo ====


Como passo nmero 10 pronto, agora precisamos configurar um endereo IP na interface
FastEthernet 0 do roteador. Esse endereo ser utilizado por ele mesmo na deciso de
roteamento de pacotes e tambm como um ponto para acesso remoto (telnet). O endereo que
ser um da classe A para que todos possam ter acesso aos outros laboratrios.
R1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)# interface Ethernet 0/0
R1(configif)# ip address 10.1.1.1 255.255.255.0
R1(configif)# no shutdown
R1(configif)# end
R1#

==== 12 Passo ====


Salve as configuraes:
R1# copy runningconfig startupconfig
Destination filename [startupconfig]?
Building configuration...
[OK]

LIO MANDAR PRA MEU E-MAIL:


cisco.alexandre.ccna@gmail.com