You are on page 1of 34

Switch 1

CONFIGURATION
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#exit
S1(config)#line vty 04
S1(config-line)#password unikl
S1(config-line)#exit
S1(config)#enable password miit
S1(config)#banner motd "Welcome to S1"
S1(config)#exit

SHOW RUN

Welcome to S1

S1>en
Password:
S1#show run
Building configuration...

Current configuration : 1140 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
enable password miit
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!

interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!

interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
banner motd ^CWelcome to S1^C
!
!
!
line con 0
password cisco
!
line vty 0 3
login
line vty 4
password unikl
login
line vty 5 15
login
!
!

End

Switch 2
CONFIGURATION
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S2
S2(config)#line console 0
S2(config-line)#password cisco
S2(config-line)#exit
S2(config)#line vty 04
S2(config-line)#password unikl
S2(config-line)#exit
S2(config)#enable password miit
S2(config)#banner motd "Welcome to S2"
S2(config)#exit

SHOW RUN
Welcome to S2

S2>en
Password:

S2#show run
Building configuration...

Current configuration : 1140 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
enable password miit
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!

interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!

interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
banner motd ^CWelcome to S2^C
!
!
!
line con 0
password cisco
!
line vty 0 3
login
line vty 4
password unikl
login
line vty 5 15
login
!
!
end

Switch 3
CONFIGURATION
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S3
S3(config)#line console 0
S3(config-line)#password cisco
S3(config-line)#exit
S3(config)#line vty 04
S3(config-line)#password unikl
S3(config-line)#exit
S3(config)#enable password miit
S3(config)#banner motd "Welcome to S3"
S3(config)#exit

SHOW RUN
Welcome to S3

S3>en
Password:
S3#show run
Building configuration...

Current configuration : 1140 bytes

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S3
!
enable password miit
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!

interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!

interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
banner motd ^CWelcome to S3^C
!
!
!
line con 0
password cisco
!
line vty 0 3
login
line vty 4
password unikl
login
line vty 5 15
login
!
!
end

Router 1
CONFIGURATION
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#exit
R1(config)#service password-encryption
R1(config)#line vty 04
R1(config-line)#password unikl
R1(config-line)#exit
R1(config)#enable password miit
R1(config)#banner motd "Welcome to R1"
R1(config)#exit

SHOW RUN
Welcome to R1

R1>en
Password:
R1#show run
Building configuration...

Current configuration : 1245 bytes


!
version 15.1
no service timestamps log datetime msec

no service timestamps debug datetime msec


service password-encryption
!
hostname R1
!
!
!
enable password 7 082C45471D
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15240NFJ
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!

!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 200.100.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 200.100.5.2 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
ip address 200.100.6.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown

!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 200.100.2.0 0.0.0.3 area 0
network 200.100.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd ^CWelcome to R1^C
!
!
!
!
line con 0
password 7 0822455D0A16
!
line aux 0
!
line vty 0 3
login
line vty 4
password 7 083442470215

login
!
!
!
end

SHOW IP OSPF
R1#show ip ospf neighbor
Neighbor ID

Pri State

200.100.2.1

0 FULL/ -

Dead Time Address


00:00:37

200.100.1.2

Interface
Serial0/0/0

Router 2
CONFIGURATION
Router>EN
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#exit
R2(config)#line vty 04
R2(config-line)#password unikl
R2(config-line)#exit
R2(config)#service password-encryption
R2(config)#enable password miit
R2(config)#banner motd "Welcome to R2"
R2(config)#exit

SHOW RUN
Welcome to R2

R2>en
Password:
R2#show run
Building configuration...

Current configuration : 1143 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R2
!
!
!
enable password 7 082C45471D
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524ZJCC
!
!
!
!

!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 200.100.2.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 200.100.1.2 255.255.255.252

clock rate 2000000


!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 200.100.1.0 0.0.0.3 area 0
network 200.100.2.0 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd ^CWelcome to R2^C
!
!
!
!

line con 0
password 7 0822455D0A16
!
line aux 0
!
line vty 0 3
login
line vty 4
password 7 083442470215
login
!
!
!
end

SHOW IP OSPF
R2#show ip ospf neighbor
Neighbor ID

Pri State

Dead Time Address

Interface

200.100.3.1

0 FULL/ -

00:00:35

200.100.2.2

Serial0/0/0

200.100.6.1

0 FULL/ -

00:00:39

200.100.1.1

Serial0/0/1

Router 3
CONFIGURATION
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3

R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#exit
R3(config)#service password-encryption
R3(config)#line vty 04
R3(config-line)#password unikl
R3(config-line)#exit
R3(config)#enable password miit
R3(config)#banner motd "Welcome to R3 "
R3(config)#exit

SHOW RUN
Welcome to R3

R3>en
Password:
R3#show run
Building configuration...

Current configuration : 1144 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R3
!
!
!
enable password 7 082C45471D
!

!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15242KLS
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto

shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 200.100.3.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 200.100.2.2 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes

network 200.100.2.0 0.0.0.3 area 0


network 200.100.3.0 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd ^CWelcome to R3 ^C
!
!
!
!
line con 0
password 7 0822455D0A16
!
line aux 0
!
line vty 0 3
login
line vty 4
password 7 083442470215
login
!
!
!
end

SHOW IP OSPF
R3#show ip ospf neighbor
Neighbor ID

Pri State

Dead Time Address

Interface

200.100.6.2

0 FULL/ -

00:00:39

200.100.3.2

Serial0/0/0

200.100.2.1

0 FULL/ -

00:00:39

200.100.2.1

Serial0/0/1

Router 4
CONFIGURATION
Router>en
Router#config t
Router(config)#hostname R4
R4(config)#line console 0
R4(config-line)#password cisco
R4(config-line)#exit
R4(config)#service password-encryption
R4(config)#line vty 04
R4(config-line)#password unikl
R4(config-line)#exit
R4(config)#enable password miit
R4(config)#banner motd "Welcome to R4"
R4(config)#exit

SHOW RUN
Welcome to R4

R4>en
Password:
R4#show run
Building configuration...

Current configuration : 1245 bytes


!
version 15.1
no service timestamps log datetime msec

no service timestamps debug datetime msec


service password-encryption
!
hostname R4
!
!
!
enable password 7 082C45471D
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524P67G
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!

!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 200.100.4.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 200.100.3.2 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 200.100.6.2 255.255.255.252
clock rate 2000000

!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 200.100.3.0 0.0.0.3 area 0
network 200.100.4.0 0.0.0.3 area 0
network 200.100.6.0 0.0.0.3 area 0
network 192.168.3.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd ^CWelcome to R4^C
!
!
!
!
line con 0
password 7 0822455D0A16
!
line aux 0
!
line vty 0 3
login
line vty 4
password 7 083442470215

login
!
!
!
end

SHOW IP OSPF
R4#show ip ospf neighbor
Neighbor ID

Pri State

Dead Time Address

Interface

200.100.3.1

0 FULL/ -

00:00:30

200.100.3.1

Serial0/0/1

200.100.5.1

0 FULL/ -

00:00:30

200.100.4.2

Serial0/0/0

Router 5
CONFIGURATION
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R5
R5(config)#line console 0
R5(config-line)#password cisco
R5(config-line)#exit
R5(config)#service password-encryption
R5(config)#line vty 04
R5(config-line)#password unikl
R5(config-line)#exit
R5(config)#enable password miit
R5(config)#banner motd "Welcome to R5"

R5(config)#exit

SHOW RUN
Welcome to R5

R5>en
Password:
R5#show run
Building configuration...

Current configuration : 1194 bytes


!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R5
!
!
!
enable password 7 082C45471D
!
!
!
!
no ip cef
no ipv6 cef
!
!
!

!
license udi pid CISCO1941/K9 sn FTX1524L972
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0

ip address 200.100.5.1 255.255.255.252


clock rate 2000000
!
interface Serial0/0/1
ip address 200.100.4.2 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 200.100.4.0 0.0.0.3 area 0
network 200.100.5.0 0.0.0.3 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
!

!
banner motd ^CWelcome to R5^C
!
!
!
!
line con 0
password 7 0822455D0A16
!
line aux 0
!
line vty 0 3
login
line vty 4
password 7 083442470215
login
!
!
!
end

SHOW IP OSPF
R5#show ip ospf neighbor
Neighbor ID
200.100.6.2

Pri State
0 FULL/ -

Dead Time Address


00:00:33

200.100.4.1

Interface
Serial0/0/1

You might also like