You are on page 1of 13

Taller de Telefona IP TM402

Lab 2: Definicin de
Configuraciones en un
CUCME

Document Version: 15/06/2017

1
1. Introduccin
En este laboratorio terico, se presentar una configuracin tpica de un CUCME mostrando
los diferentes servicios y capacidades que se pueden realizar

2. Objetivos
Detectar y reconocer los comandos telefnicos en un CUCME
Saber definir y clasificar cada comando telefnico en un CUCME
Comprender y saber explicar que est realizando cada comando ejecutado en el ejemplo de
este Laboratorio
Detectar una posibles fallas en la configuracin y corregirlas

3. Topologa
Usuarios
Fonos SCCP

IP

IP

IP

IP

Usuarios
Fonos SIP
Gi0/0 E1 0/0/0
PSTN
IP CME
10.10.1.1
IP

IP

IP NTP SERVER
10.10.1.5

3.1 Direcciones IP
Name Device Type IP Addresses/Digital connection
Gi0/0 Serial0/0/0 Serial0/1/0-2
CME Router Cisco 10.10.1.1/24 E1 PRI N/A
2901
Servidor NTP server 10.10.1.5/24 N/A N/A
Phone: 1001 8811 DHCP N/A N/A
Phone: 1002 7821 DHCP N/A N/A
Phone: 1003 7821 DHCP N/A N/A
Phone: 1004 7811 DHCP N/A N/A
Phone: 1005 7942 DHCP N/A N/A
Phone: 1006 79
7942 DHCP N/A N/A
Phone: 1007 7942 DHCP N/A N/A
Phone: 1008 7942 DHCP N/A N/A

3.2 Nmeros de Telfono y Direcciones MAC


IP Phones: 88XX, 78XX, 79XX
Device Telephone Number MAC Address
IPPhone: 1001 1001 DCCE.C114.957E

2
IPPhone: 1002 1002 0057.D2D0.66B0
IPPhone: 1003 1003 0057.D2D0.6699
IPPhone: 1004 1004 9C57.ADD3.C1B5
IPPhone: 1005 1005 AC44.F211.AE55
IPPhone: 1006 1006 6CFA.8995.AB8C
IPPhone: 1007 1007 6CFA.8995.372F
IPPhone: 1008 1008 6CFA.8995.390B

4. Tarea 1. Reconocer comandos de telefona (10 ptos)


En este apartado, se presentaran distintos comandos de la configuracin mostrada en el Anexo
A de este documento. Respecto de esto responder con una definicin a cada comando,
indicando principalmente cual es el objetivo de este para la telefona de la red planteada en el
punto 3.

4.1 option 150 ip 10.10.1.254:

4.2 voice class codec 1:

4.3 voice register dn 1:

4.4 voice register pool 1:

4.5 type 7821:

4.6 pri-group timeslots 1-31:

4.7 destination-pattern 9700.......:

4.8 ip source-address 10.10.1.1 port 2000:

4.9 ephone-dn 5:

4.10 ephone 5:

5
5. Tarea 2. Reconocer estructuras de comandos de telefona
(total: 10 ptos)
En este apartado, se presentaran distintas estructuras de comandos de la configuracin
mostrada en el Anexo A de este documento. Respecto de esto responder con una definicin a
cada estructura, indicando principalmente cual es el objetivo de este para la telefona de la
red planteada en el punto 3.

5.1 voice register global


mode cme
source-address 10.10.1.1 port 5060
max-dn 35
max-pool 35
timezone 18
date-format D/M/Y
service https
url directory http://10.10.1.1/localdirectory
tftp-path flash:
create profile sync 1132911094133051
network-locale ES
user-locale ES load CME-locale-es_ES-Spanish-10.5.3.0.tar
user-locale 1 ES

Objetivo:

5.2 voice service voip


allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol pass-through g711alaw
h323
sip
registrar server

Objetivo:

5.3 controller E1 0/0/0


framing NO-CRC4
pri-group timeslots 1-31
description E1_Pri_Publica

Objetivo:

5
5.4 tftp-server flash:sip78xx.10-1-1SR1-4.loads
tftp-server flash:rootfs78xx.10-1-1SR1-4.sbn
tftp-server flash:sboot78xx.10-1-1SR1-4.sbn
tftp-server flash:kern78xx.10-1-1SR1-4.sbn
tftp-server sip8831.9-3-3-5.loads
tftp-server sboot8831.9-3-3-5.sebn
tftp-server rootfs8831.9-3-3-5.sebn
tftp-server kern8831.9-3-3-5.sebn
tftp-server flash:its/CME-locale-es_ES-Spanish-10.5.3.0.tar
tftp-server flash:/mk-sccp.jar
tftp-server flash:/mk-sccp.jar alias user_define_1/mk-sccp.jar
tftp-server SCCP42.9-4-2-1S.loads
tftp-server apps42.9-4-2TH1-1.sbn
tftp-server appscnu42.9-4-2TH1-1.sbn
tftp-server cnu42.9-4-2TH1-1.sbn
tftp-server cvm42sccp.9-4-2TH1-1.sbn
tftp-server dsp42.9-4-2TH1-1.sbn
tftp-server jar42sccp.9-4-2TH1-1.sbn
tftp-server term42.default.loads
tftp-server term62.default.loads
tftp-server flash:S00104000100.SBN
tftp-server flash:S00105000400.sbn

Objetivo:

5.5 dial-peer cor custom


name NAC
name CEL
name LDI
name INT
name L600
name L700
name L800
name INFOEMER
!
dial-peer cor list USR
member INT
member INFOEMER
!
dial-peer cor list USR-NAC
member NAC
member INT
member L800
member INFOEMER
!
dial-peer cor list USR-NAC-CEL
member NAC
member CEL
member INT
member L800
member INFOEMER
!
dial-peer cor list USR-NAC-CEL-LDI
member NAC
member CEL
member LDI
member INT
member L600
member L700
member L800
member INFOEMER

Objetivo:

5
6. Tarea 3. Reconocer fallas en las configuraciones de
telefona y corregirlas (total: 5 ptos)

En este apartado, debers encontrar 5 fallas en las configuraciones del anexo A y corregirlas.
Observacin: en rojo se encontrars 4 de 5 las estructuras con falla de configuracin, solo una
falla no estn resaltada en rojo.

Falla 1:

Falla 2:

Falla 3:

Falla 4:

Falla 5:

7. ANEXO A
VOICE_GW#sho run
Building configuration...

Current configuration : 11505 bytes


!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VOICE_GW_CME
!
boot-start-marker
boot system flash c2900-universalk9-mz.SPA.156-1.T1.bin
boot-end-marker
!
card type e1 0 0
!
logging buffered 51200 warnings
enable secret 5 $1$ocE3$AyiWLWw7AcUH.Zx9lUy4q1
!
no aaa new-model
ethernet lmi ce
!
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
ip dhcp excluded-address 10.10.1.1 10.10.1.10
!
ip dhcp pool telefonia
network 10.10.1.0 255.255.255.0
default-router 10.10.1.1
option 150 ip 10.10.1.254
lease 0 8
!
no ip domain lookup
ip domain name labvoip.com
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
5
isdn switch-type primary-net5
!
!
trunk group PSTN
hunt-scheme round-robin both
!
cts logging verbose
!
crypto pki trustpoint TP-self-signed-3603117662
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3603117662
revocation-check none
rsakeypair TP-self-signed-3603117662
!
!
crypto pki certificate chain TP-self-signed-3603117662
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33363033 31313736 3632301E 170D3135 31323232 31383338
34395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 36303331
31373636 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100B5CA 4A1ED30E 6AD4A0FB F38B5764 13D01626 0A052DC3 7A9A2126 42357766
922A33CB C13A1274 72E20ECD 5B44BBB3 FD3C52A7 DADFE431 466B4D9F 885E8620
71A9EB1A 5CF88F8E C23FDE8B BE3C8E95 6CA76DED AEE03B5F 4348D615 7B36AD73
4275B8B0 D91CDC7D 05B89222 07EDFAAC 7BCA4232 E504558F EDABA482 711B05CD
93090203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 144BCE63 666BD54B E6044F2B 74E465ED D255D5CE C9301D06
03551D0E 04160414 4BCE6366 6BD54BE6 044F2B74 E465EDD2 55D5CEC9 300D0609
2A864886 F70D0101 05050003 8181003F 59C0C132 E3988C8B D4772D07 0D3EBAE0
8A7C03A1 795ABA63 299FB025 B409014E 794C0592 FE0A4975 79BA3078 331DEA1B
E7DBC20B 275A25F3 7AAFD1F6 6D1C9418 AEFBEBCD 745AADA8 D4D17A35 FC5B1725
0B9D672B CA3B8A76 C13DCD7E E12FEF6B BF584AAF E656873F 4A500F36 160C055A
14772C41 0A87C589 EF8B3125 0C2FE3
quit
voice-card 0
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol pass-through g711alaw
h323
sip
registrar server
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice register global
mode cme
source-address 10.10.1.1 port 2000
max-dn 35
max-pool 35
timezone 18
date-format D/M/Y
service https
url directory http://10.10.1.1/localdirectory
tftp-path flash:
create profile sync 1132911094133051
network-locale ES
user-locale ES load CME-locale-es_ES-Spanish-10.5.3.0.tar
user-locale 1 ES
!
voice register dn 1
number 1001
pickup-group 100

5
name Recepcion 1001
label Recepcion 1001
!
voice register dn 2
number 1002
pickup-group 100
name Mariano Trullenque 1002
label Mariano Trullenque 1002
!
voice register dn 10
number 1003
pickup-group 100
name Ronald Paz 1003
label Ronald Paz 1003
!
voice register dn 11
number 1004
pickup-group 100
name Sala Reuniones 1004
label Sala Reuniones 1004
!
voice register pool 1
busy-trigger-per-button 2
id mac DCCE.C114.957E
type 8811
number 1 dn 1
dtmf-relay rtp-nte
username cisco1 password a
codec g711ulaw
!
voice register pool 2
busy-trigger-per-button 2
id mac 0057.D2D0.66B0
type 7821
number 1 dn 2
cor incoming USR-NAC-CEL default
dtmf-relay rtp-nte
username cisco2 password a
codec g711ulaw
!
voice register pool 10
busy-trigger-per-button 2
id mac 0057.D2D0.6699
type 7821
number 1 dn 10
dtmf-relay rtp-nte
username cisco10 password a
codec g711ulaw
!
voice register pool 11
busy-trigger-per-button 2
id mac 9C57.ADD3.C1B5
type 7811
number 1 dn 11
dtmf-relay rtp-nte
username cisco11 password a
codec g711ulaw
!
!
!
license udi pid CISCO2921/K9 sn FTX1835AHH6
hw-module pvdm 0/0
!
!
!
redundancy
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
description E1_Pri_Publica
!

5
!
class-map match-any voip
match ip precedence 5
class-map match-any datos
match ip precedence 3
!
policy-map QoS
class voip
priority percent 20
class datos
set precedence 3
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description *** LAN VOZ ***
ip address 10.10.1.1 255.255.255.0
duplex auto
speed auto
service-policy output QoS
shutdown
!
interface GigabitEthernet0/1
no ip address
shutdown
!
!
tftp-server flash:sip78xx.10-1-1SR1-4.loads
tftp-server flash:rootfs78xx.10-1-1SR1-4.sbn
tftp-server flash:sboot78xx.10-1-1SR1-4.sbn
tftp-server flash:kern78xx.10-1-1SR1-4.sbn
tftp-server sip8831.9-3-3-5.loads
tftp-server sboot8831.9-3-3-5.sebn
tftp-server rootfs8831.9-3-3-5.sebn
tftp-server kern8831.9-3-3-5.sebn
tftp-server flash:its/CME-locale-es_ES-Spanish-10.5.3.0.tar
tftp-server flash:/mk-sccp.jar
tftp-server flash:/mk-sccp.jar alias user_define_1/mk-sccp.jar
tftp-server SCCP42.9-4-2-1S.loads
tftp-server apps42.9-4-2TH1-1.sbn
tftp-server appscnu42.9-4-2TH1-1.sbn
tftp-server cnu42.9-4-2TH1-1.sbn
tftp-server cvm42sccp.9-4-2TH1-1.sbn
tftp-server dsp42.9-4-2TH1-1.sbn
tftp-server jar42sccp.9-4-2TH1-1.sbn
tftp-server term42.default.loads
tftp-server term62.default.loads
tftp-server flash:S00104000100.SBN
tftp-server flash:S00105000400.sbn
!
control-plane
!
!
voice-port 0/0/0:15
bearer-cap Speech
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
!
!
dial-peer cor custom
name NAC
name CEL
name LDI
name INT
name L600

5
name L700
name L800
name INFOEMER
!
dial-peer cor list USR
member INT
member INFOEMER
!
dial-peer cor list USR-NAC
member NAC
member INT
member L800
member INFOEMER
!
dial-peer cor list USR-NAC-CEL
member NAC
member CEL
member INT
member L800
member INFOEMER
!
dial-peer cor list USR-NAC-CEL-LDI
member NAC
member CEL
member LDI
member INT
member L600
member L700
member L800
member INFOEMER
!
dial-peer cor list Nacional
member NAC
!
dial-peer cor list Celular
member CEL
!
dial-peer cor list Internacional
member LDI
!
dial-peer cor list linea600
member L600
!
dial-peer cor list linea700
member L700
!
dial-peer cor list linea800
member L800
!
dial-peer cor list InfoEmer
member INFOEMER
!
dial-peer voice 800 pots
corlist outgoing linea800
destination-pattern 9800......
direct-inward-dial
port 0/0/0:15
forward-digits 9
!
dial-peer voice 133 pots
corlist outgoing Emergencias
description Emergencias
destination-pattern 913.
direct-inward-dial
port 0/0/0:15
forward-digits 3
!
dial-peer voice 970 pots
corlist outgoing linea700
description Salida_700
destination-pattern 9700.......
direct-inward-dial
port 0/0/0:15

5
forward-digits 10
!
dial-peer voice 918 pots
corlist outgoing Internacional
description Salida_Internacional
destination-pattern 91230T
direct-inward-dial
port 0/0/0:15
prefix 1230
!
dial-peer voice 908 voip
corlist outgoing Celular
description Salida_Celular
destination-pattern 99........
direct-inward-dial
port 0/0/0:15
forward-digits 9
!
dial-peer voice 100 pots
corlist outgoing InfoEmer
description Informaciones
destination-pattern 910.
direct-inward-dial
port 0/0/0:15
forward-digits 3
!
dial-peer voice 1404 pots
corlist outgoing InfoEmer
description EmergenciasACHS
destination-pattern 91404
direct-inward-dial
port 0/0/0:15
forward-digits 4
!
dial-peer voice 600 pots
corlist outgoing linea600
description llamadas Servicios600
destination-pattern 9600.......
direct-inward-dial
port 0/0/0:15
forward-digits 10
!
dial-peer voice 910 pots
corlist outgoing Nacional
description NACIONAL
destination-pattern 9[2-5]........
direct-inward-dial
port 0/1/0
forward-digits 9
!
dial-peer voice 911 pots
corlist outgoing Nacional
description NACIONAL
destination-pattern 97........
direct-inward-dial
port 0/0/0:15
forward-digits 9
!
dial-peer voice 912 pots
corlist outgoing Nacional
description NACIONAL
destination-pattern 96[1-7].......
direct-inward-dial
port 0/0/0:15
forward-digits 9
!
!
telephony-service
max-ephones 10
max-dn 20
ip source-address 10.10.1.1 port 5060
cnf-file location flash:
time-zone 12

5
time-format 24
date-format dd-mm-yy
max-conferences 8 gain -6
call-park system application
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 5 dual-line
number 1005
pickup-call any-group
label Manuel Rodriguez
description Manuel Rodriguez 1005
name Manuel Rodriguez
corlist incoming USR-LCL
!
!
ephone-dn 6 dual-line
number 1006
pickup-call any-group
label Patricia Guerra
description Patricia Guerra 1006
name Patricia Guerra
!
!
ephone-dn 7 dual-line
number 1007
label jorge yugovic
description jorge yugovic 1007
name jorge yugovic
!
!
ephone-dn 8 dual-line
number 1008
pickup-group 31
label Janet Lopez
description Janet Lopez 1008
name Janet Lopez
!
!
!
ephone 5
description "Manuel Rodriguez 1005"
mac-address AC44.F211.AE55
type 7942
button 1:5
!
!
!
ephone 6
description "Patricia Guerra 1006"
mac-address 6CFA.8995.AB8C
type 7942
button 1:6
!
!
!
ephone 7
description "jorge yugovic 1007"
mac-address 6CFA.8995.372F
type 7942
button 1:7
!
!
!
ephone 8
description "Janet Lopez 1008"
mac-address 6CFA.8995.390B
type 7942
button 1:8
!
!
line con 0

5
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password labvoice
login
transport input all
!
scheduler allocate 20000 1000
ntp master
ntp server 10.10.1.5 source GigabitEthernet0/0
!
end