You are on page 1of 8

Nexus Technology Labs Classical Ethernet

Switching

Core Nexus LAN Switching


Last updated: April 11, 2013

Task
Configure N7K1, N7K2, N5K1, and N5K2 as follows so that IP connectivity is established
between Server 1 and Server 2:
Create VLAN 10 on N7K1, N7K2, N5K1, and N5K2.
Assign VLAN 10 as the access VLAN for N5K1's connection to Server 1; Server 1
should use the IP address 10.0.0.1/24.
Assign VLAN 10 as the access VLAN for N5K2's connection to Server 2; Server 2
should use the IP address 10.0.0.2/24.
Statically set these links to 1Gbps on N5K1 and N5K2, respectively.
Configure 802.1Q Trunking between the switches as follows:
N5K1's links to N7K1 should all be trunks.
N5K2's links to N7K2 should all be trunks.
N7K1's links to N7K2 should all be trunks.
Edit the trunking allowed list so that only VLANs 1 and 10 will forward over these links.
Disable all other interconnections between the switches.
When complete, Server 1 and Server 2 should have IP connectivity to each other.

Configuration

N5K1:
vlan 1,10
!
interface Ethernet1/1
switchport access vlan 10
speed 1000
no shutdown
!
interface Ethernet1/2 - 5
shutdown
!
interface Ethernet1/6 FEEDBACK
switchport mode trunk
switchport trunk allowed vlan 1,10
no shutdown
!
interface Ethernet1/7
switchport mode trunk
switchport trunk allowed vlan 1,10
no shutdown
!
interface Ethernet1/8 - 9
shutdown

N5K2:
vlan 1,10
!
interface Ethernet1/1
shutdown
!
interface Ethernet1/2
switchport access vlan 10
speed 1000
no shutdown
!
interface Ethernet1/3 - 5
shutdown
!
interface Ethernet1/6
switchport mode trunk
switchport trunk allowed vlan 1,10
no shutdown
!
interface Ethernet1/7
switchport mode trunk
switchport trunk allowed vlan 1,10
no shutdown
!
interface Ethernet1/8 - 9
shutdown

N7K1:
vlan 1,10
!
interface Ethernet1/1 - 2, Ethernet2/1 - 4
switchport
switchport mode trunk
switchport trunk allowed vlan 1,10
no shutdown

N7K2:
vlan 1,10
!
interface Ethernet1/1 - 2, Ethernet2/1 - 4
switchport
switchport mode trunk
switchport trunk allowed vlan 1,10
no shutdown

Verification
Server 1 is able to reach Server 2 on the local LAN segment:

Only the required interfaces are connected. Links to the end servers run at 1Gbps, whereas the
trunks between the switches run at 10Gbps:
N5K1# show interface status

--------------------------------------------------------------------------
------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------
------
Eth1/1 -- connected 10 full 1000 SFP-
1000BAS
Eth1/2 -- disabled 1 full 10G SFP-1
000BAS
Eth1/3 -- disabled 1 full 10G SFP-H
10GB-C
Eth1/4 -- disabled 1 full 10G SFP-H
10GB-C
Eth1/5 -- disabled 1 full 10G SFP-H
10GB-C
Eth1/6 -- connected trunk full 10G SFP-
H10GB-C
Eth1/7 -- connected trunk full 10G SFP-
H10GB-C
Eth1/8 -- disabled 1 full 10G SFP-H
10GB-C
Eth1/9 -- disabled 1 full 10G SFP-H
10GB-C

VLAN 10 is created and forwarding on the required interfaces:

N5K1# show vlan brief

VLAN Name Status Ports


---- -------------------------------- --------- --------------------------
-----
1 default active Eth1/2, Eth1/3, Eth1/4, Et
h1/5
Eth1/6, Eth1/7, Eth1/8, Et
h1/9
Eth1/10, Eth1/11, Eth1/12
Eth1/13, Eth1/14, Eth1/15
Eth1/16, Eth1/17, Eth1/18
Eth1/19, Eth1/20, Eth1/21
Eth1/22, Eth1/23, Eth1/24
Eth1/25, Eth1/26, Eth1/27
Eth1/28, Eth1/29, Eth1/30
Eth1/31, Eth1/32
10 VLAN0010 active Eth1/1, Eth1/6, Eth1/7
VLANs 1 and 10 are trunking on the required interfaces, and other VLANs have been removed
from the allowed list:

N7K1# show interface trunk

--------------------------------------------------------------------------
------
Port Native Status Port
Vlan Channel
--------------------------------------------------------------------------
------
Eth1/1 1 trunking --
Eth1/2 1 trunking --
Eth2/1 1 trunking --
Eth2/2 1 trunking --
Eth2/3 1 trunking --
Eth2/4 1 trunking --

--------------------------------------------------------------------------
------
Port Vlans Allowed on Trunk
--------------------------------------------------------------------------
------
Eth1/1 1,10
Eth1/2 1,10
Eth2/1 1,10
Eth2/2 1,10
Eth2/3 1,10
Eth2/4 1,10

--------------------------------------------------------------------------
------
Port Vlans Err-disabled on Trunk
--------------------------------------------------------------------------
------
Eth1/1 none
Eth1/2 none
Eth2/1 none
Eth2/2 none
Eth2/3 none
Eth2/4 none

--------------------------------------------------------------------------
------
Port STP Forwarding
--------------------------------------------------------------------------
------
Eth1/1 1,10
Eth1/2 none
Eth2/1 none
Eth2/2 none
Eth2/3 1,10
Eth2/4 1,10

--------------------------------------------------------------------------
------
Port Vlans in spanning tree forwarding state and not pruned
--------------------------------------------------------------------------
------
Eth1/1 1,10
Eth1/2 none
Eth2/1 none
Eth2/2 none
Eth2/3 1,10
Eth2/4 1,10
<snip>

All four switches agree on who the root of the Spanning-Tree is for VLAN 10, and alternate paths
to the root bridge are blocked:

N5K1# show spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0026.980c.2141
Cost 4
Port 134 (Ethernet1/6)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)


Address 547f.ee79.137c
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type


---------------- ---- --- --------- -------- -----------------------------
---
Eth1/1 Desg FWD 4 128.129 P2p
Eth1/6 Root FWD 2 128.134 P2p
Eth1/7 Altn BLK 2 128.135 P2p

N5K2# show spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0026.980c.2141
Cost 2
Port 134 (Ethernet1/6)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)


Address 547f.ee7a.4d7c
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type


---------------- ---- --- --------- -------- -----------------------------
---
Eth1/2 Desg FWD 4 128.130 P2p
Eth1/6 Root FWD 2 128.134 P2p
Eth1/7 Altn BLK 2 128.135 P2p

N7K1# show spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0026.980c.2141
Cost 2
Port 129 (Ethernet1/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)


Address 68bd.abd7.6041
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type


---------------- ---- --- --------- -------- -----------------------------
---
Eth1/1 Root FWD 2 128.129 P2p
Eth1/2 Altn BLK 2 128.130 P2p
Eth2/1 Altn BLK 2 128.257 P2p
Eth2/2 Altn BLK 2 128.258 P2p
Eth2/3 Desg FWD 2 128.259 P2p
Eth2/4 Desg FWD 2 128.260 P2p

N7K2# show spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0026.980c.2141
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)


Address 0026.980c.2141
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- -----------------------------
---
Eth1/1 Desg FWD 2 128.129 P2p
Eth1/2 Desg FWD 2 128.130 P2p
Eth2/1 Desg FWD 2 128.257 P2p
Eth2/2 Desg FWD 2 128.258 P2p
Eth2/3 Desg FWD 2 128.259 P2p
Eth2/4 Desg FWD 2 128.260 P2p

Server 1 and Server 2's MAC addresses are learned in the VLAN 10 CAM table:

N5K1# show mac address-table dynamic vlan 10


Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay
MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Lin
k
VLAN MAC Address Type age Secure NTFY Ports/SWID.SS
ID.LID
---------+-----------------+--------+---------+------+----+---------------
---
* 10 000c.29d0.a588 dynamic 180 F F Eth1/6
* 10 000c.29f8.57ec dynamic 250 F F Eth1/1

^ back to top

Disclaimer (http://www.ine.com/feedback.htm) | Privacy Policy (http://www.ine.com/resources/) | 2013 INE


Inc., All Rights Reserved (http://www.ine.com/about-us.htm)

You might also like