You are on page 1of 8

ECUACION DE SEGUNDO GRADO un 70% y el restante 30% lo pagar solicitando crdito al

fabricante.
Hacer un algoritmo para resolver una ecuacin de
segundo grado. La ecuacin de segundo grado es ax2 + bx El fabricante cobra por concepto de intereses un 20%
+ c = 0 y a 0. Las soluciones o races de la ecuacin son: sobre la cantidad que se le pague a crdito.

Hacer un algoritmo que determine cmo se pagara una


compra determinada.

SERVICIO MILITAR

Una persona es apta para prestar el servicio militar


obligatorio cuando: es mayor de 18 aos, menor de 25
aos, y gnero masculino. Realizar un algoritmo que
permita determinar si una persona es apta o no para
prestar el servicio militar.

VALOR MATRICULA

Se ha establecido un programa para estimular a los


alumnos, el cual consiste en lo siguiente: si el promedio
global obtenido por un alumno en el ltimo periodo es
mayor o igual que 4, se le har un descuento del 30% sobre
la matrcula y no se le cobrar IVA; si el promedio obtenido
es menor que 4 deber pagar la matrcula completa, la
cual debe incluir el 10% de IVA. Hacer un algoritmo que
calcule el valor a pagar si se conocen las notas finales de
las 6 materias que cursaron.
MONTO DE COMPRA

Una empresa quiere hacer una compra de varias piezas de


la misma clase a una fbrica. La empresa, dependiendo del
monto total de la compra, decidir qu hacer para pagar
al fabricante.

Si el monto total de la compra excede de $500.000 la


empresa tendr la capacidad de invertir de su propio
dinero un 55% del monto de la compra, pedir prestado al
banco un 30% y el resto lo pagar solicitando un crdito al
fabricante.

Si el monto total de la compra no excede de $500 000 la


empresa tendr capacidad de invertir de su propio dinero DESCUENTO COMPRA

1
Una tienda ha puesto en oferta la venta al por mayor de
cierto producto, ofreciendo un descuento del 15% por la
compra de ms de 3 docenas y 10% en caso contrario.
Disee un algoritmo que determine el monto de la
compra, el monto del descuento y el monto a pagar.

ESTACIONAMIENTO

En una playa de estacionamiento cobran $1500 la primera


hora y $1000 a partir de la segunda hora. Disee un
algoritmo que determine cunto debe pagar un cliente
por el estacionamiento de su vehculo, conociendo el
tiempo de estacionamiento en horas.

DESCUENTO NUMERO AZAR

En un supermercado se hace una promocin, mediante la


cual el cliente obtiene un descuento dependiendo de un
nmero que se escoge al azar. Si el nmero escogido es
menor que 74 el descuento es del 15% sobre el total de la FUNCION PARTE DECIMAL
compra, si es mayor o igual a 74 el descuento es del 20%.
Obtener cunto dinero se le descuenta.
Hacer un programa que determine si un nmero tiene o
no parte fraccionaria. Usar la funcin trunc la cual elimina
la parte decimal de un nmero real. trunc es similar a la
funcin parte entera, por ejemplo [2.5] es 2.

NOTA CURSO

Determinar si un alumno aprueba o reprueba un curso,


sabiendo que aprobar si su promedio de tres
calificaciones es mayor o igual a 3.0; reprueba en caso
NUMERO PAR/IMPAR
contrario.
Disee un algoritmo que determine si un nmero es o no
par.

2
Proceso Mayor_Ascendente

Escribir "Ingrese el primer numero";


Leer n1;
Escribir "Ingrese el segundo numero";
Leer n2;
Escribir "Ingrese el tercer numero";
Leer n3;
mayor <- 0;
Si n1 > n2 Entonces
Proceso Menos_Descendente
mayor <- n1;
medio <- n3;
Escribir "Ingrese el primer numero";
menor <- n2;
Leer n1;
Si n1 < n3 Entonces
Escribir "Ingrese el segundo numero";
mayor <- n3;
Leer n2;
medio <- n2;
Escribir "Ingrese el tercer numero";
menor <- n1;
Leer n3;
Sino
mayor <- 0;
Si n2 > n3 Entonces
Si n1 > n2 Entonces
medio <- n2;
mayor <- n1;
menor <- n3;
medio <- n3;
FinSi
menor <- n2;
FinSi
Si n1 < n3 Entonces
Sino
mayor <- n3;
mayor <- n2;
medio <- n2;
medio <- n3;
menor <- n1;
menor <- n1;
Sino
Si n2 < n3 Entonces
Si n2 > n3 Entonces
mayor <- n3;
medio <- n2;
menor <- n1;
menor <- n3;
medio <- n2;
FinSi
Sino
FinSi
Si n1 > n3 Entonces
Sino
medio <- n1;
mayor <- n2;
menor <- n3;
medio <- n3;
FinSi
menor <- n1;
FinSi
Si n2 < n3 Entonces
FinSi
mayor <- n3;
Escribir "Los numeros ordenados en orden
menor <- n1;
ascendente son:", " ",menor," - ",medio," - ",mayor;
medio <- n2;
FinProceso
Sino
Si n1 > n3 Entonces
3)
medio <- n1;
Proceso semana
menor <- n3;
escribir 'ingresar N de dias: ';
FinSi
leer dias;
FinSi
Segun dias Hacer
FinSi
1:
Escribir "Los numeros ordenados en orden
escribir 'lunes';
ascendente son:", " ",mayor," - ",medio," - ",menor;
2:
FinProceso
escribir 'martes';
3:
2)
escribir 'miercoles';

3
4: Segun nota Hacer
escribir 'jueves'; 0:
5: escribir 'cero';
escribir 'viernes'; 1:
6: escribir 'uno';
escribir 'sabado'; 2:
7: escribir 'dos';
escribir 'domingo'; 3:
escribir 'tres';
De Otro Modo: 4:
escribir 'numero no valido'; escribir 'cuatro';
FinSegun 5:
FinProceso escribir 'cinco';
6:
4) escribir 'seis';
Proceso mes 7:
escribir 'ingresar N de mes: '; escribir 'siete';
leer mes; 8:
Segun mes Hacer escribir 'ocho';
1: 9:
escribir 'enero'; escribir 'nueve';
2: 10:
escribir 'febrero'; escribir 'diez';
3:
escribir 'marzo'; De Otro Modo:
4: escribir 'numero no valido';
escribir 'abril'; FinSegun
5: FinProceso
escribir 'mayo';
6:
escribir 'junio'; 6)
7: Proceso notas
escribir 'julio'; promedio<-0
8: escribir 'ingresar notas del alumno: ';
escribir 'agosto'; leer n1;
9: leer n2;
escribir 'setiembre'; leer n3;
10: promedio<-(n1+n2+n3)/3
escribir 'octubre'; Si promedio>0 y promedio<5 Entonces
11: escribir 'el alumno es pesimo';
escribir 'noviembre'; Sino
12: si promedio>6 y promedio<10 Entonces
escribir 'diciembre'; escribir 'el alumno es malo';
Sino
De Otro Modo: si promedio>11 y promedio<15 Entonces
escribir 'numero no valido'; escribir 'el alumno es regular';
FinSegun Sino
FinProceso si promedio>16 y promedio<20 Entonces
escribir 'el alumno es excelente';
5) FinSi
Proceso notanumerica FinSi
escribir 'ingresar nota numerica: '; FinSi
leer nota; FinSi

4
escribir 'el promedio final es: ',promedio; FinSi
FinProceso escribir 'el monto es: ',monto1;
escribir 'el descuento es: ',descuento;
7) escribir 'el total a pagar es: ',totalapagar;
Proceso porcentaje hombre y mujeres FinProceso
total<-0
porh<-0 10)
porm<-0 Proceso pantalones
escribir 'ingresar porcentaje de hombre: '; monto1<-0
leer h; totalapagar<-0
escribir 'ingresar porcentaje de muejers: '; descuento<-0
leer m; escribir 'ingresar cantidad de pantalones: ';
total<-h+m; leer cantidad;
porh<-(h*100)/total escribir 'ingresar precio x cada pantalon: ';
escribir 'el porcentaje de hombre es: ',porh; leer precio;
porm<-(m*100)/total Si (cantidad>4) Entonces
escribir 'el porcentaje de mujeres es:',porm; monto1<-cantidad*precio;
FinProceso descuento<-monto1*0.10;
totalapagar<-monto1-descuento;
8) Sino
Proceso alumno monto1<-cantidad*precio;
total<-0 descuento<-monto1*0.05;
porh<-0 totalapagar<-monto1-descuento;
porm<-0 FinSi
escribir 'ingresar alumno Aprobados: '; escribir 'el monto es: ',monto1;
leer a; escribir 'el descuento es: ',descuento;
escribir 'ingresar alumno Desaprobado: '; escribir 'el total a pagar es: ',totalapagar;
leer d; FinProceso
total<-a+d;
porh<-(a*100)/total
escribir 'el porcentaje de aprobado es: ',porh; 11)
porm<-(d*100)/total Proceso sueldo
escribir 'el porcentaje de desaprobado es: pagar<-0
',porm; promedio<-0
FinProceso Para i<-0 Hasta 4 Con Paso 1 Hacer
escribir 'digitar sueldo: ';
9) leer sueldo;
Proceso camisas pagar<-pagar+sueldo;
monto1<-0 promedio<-pagar/4;
totalapagar<-0 FinPara
descuento<-0 escribir 'el total a pagar es: ',pagar;
escribir 'ingresar cantidad de camisas: '; escribir 'el promedio del sueldo es: ',promedio;
leer cantidad; FinProceso
escribir 'ingresar precio x cada camisas: ';
leer precio; 12)
Si (cantidad>3) Entonces Proceso descendente
monto1<-cantidad*precio; n<-12
descuento<-monto1*0.20; Mientras n>=0 Hacer
totalapagar<-monto1-descuento; escribir 'numero descendente es :',n;
Sino n<-n-1
monto1<-cantidad*precio; FinMientras
descuento<-monto1*0.10; FinProceso
totalapagar<-monto1-descuento;

5
Escribir "Para finalizar ingrese el sueldo del tercer
13) Empleado";
Proceso multiplode5 Leer Empleado3;
n<-5 Aumento1<-Empleado1*0.10;
Mientras n<=100 Hacer Salario1<-Empleado1+Aumento1;
escribir 'numero descendente es :',n; Escribir "El Sueldo con un aumento del 10% al Primer
n<-n+5 Empleado es de:", Salario1;
FinMientras Aumento2<-Empleado2*0.12;
FinProceso Salario2<-Empleado2+Aumento2;
Escribir "El sueldo con un aumento del 12% al Segundo
Empleado es de:", Salario2;
Ejercicio 1.- Aumento3<-Empleado3*0.15;
Proceso arreglo Salario3<-Empleado3+Aumento3;
Continuar<-"si"; Escribir "El sueldo con un aumento del 15% al Tercer
Mientras Continuar="si" Hacer Empleado es de:", Salario3;
Dimension C[100], P[100], G[100]; Escribir Gracias por usar Una pagina y un programa
Escribir "Ingrese la Cantidad de Viviendas que se alquilan desarrollado por Omar Web Technology;
actualmente"; FinProceso
Leer Cant_vivi;
Para i<-1 Hasta Cant_vivi Hacer Ejercicio 3.-
Escribir "Ingrese Cuanto se Paga mensualmente por la Proceso calculo_de_superficies
Vivienda,",i, ":"; opcion<-0;
Leer C[i]; Escribir "CALCULO DE SUPERFICIES (version 1.0)";
FinPara Escribir "Para hallar el Area de un Cuadrado presione 1";
Para i<-1 Hasta Cant_vivi Hacer Escribir "Para hallar el Area de un Circulo presione 2";
Escribir "Ingrese que porcentaje se obtiene de ganancia Escribir "Para hallar el Area de un Rectangulo presione
por la Vivienda,",i, ":"; 3";
Leer P[i]; Escribir "Para hallar el Area de un Trapecio presione 4";
Porcentaje<-P[i]/100; Escribir "Para hallar el Area de un Triangulo presione 5";
FinPara Leer opcion;
Para i<-1 Hasta Cant_vivi Hacer Si opcion=1 Entonces
G[i]<-C[i]*Porcentaje; Escribir "Para calcular el area de un Cuadrado, ingrese el
Escribir "La Ganancia que se obtiene de la Casa,",i, ":"; valor del lado";
Escribir "Es de:", G[i]; Leer lado;
FinPara Areacuadrado<-lado*lado;
Si Cant_vivi>100 Entonces Escribir "El valor del Area del cuadrado es de:",
Escribir "Cantidad de Viviendas no disponible"; Areacuadrado;
FinSi Escribir "Gracias por usar nuestro programa, desarrollado
Escribir "Desea continuar?"; por Pseint y el estudiante Omar";
Leer Continuar; Sino
FinMientras Si opcion=2 Entonces
Escribir Gracias por usar Una pagina y un programa Escribir "Para hallar el area de un circulo, ingrese el valor
desarrollado por Omar Web Technology; del radio";
FinProceso Leer radio;
Ejercicio 2.- Areacirculo<-3.14*radio*radio;
Proceso sueldo_de_empleados Escribir "El area de un circulo es de:", Areacirculo;
Escribir "Bienvenidos, por favor ingrese el sueldo del Escribir "Gracias por usar nuestro programa, desarrollado
primer Empleado"; por Pseint y el estudiante Omar";
Leer Empleado1; Sino
Escribir "Ahora por favor ingrese el sueldo del segundo Si opcion=3 Entonces
Empleado"; Escribir "Para hallar el valor del Rectangulo, ingrese el
Leer Empleado2; valor de la base";
Leer base;

6
Escribir "Ahora ingrese la altura"; Mientras Continuar= "s" Hacer
Leer altura; Escribir "Estimado Usuario, ingrese El nombre del
Arearectangulo<-base*altura; Paciente";
Escribir "El Area del Rectangulo es", Arearectangulo; Leer Nombre;
Escribir "Gracias por usar nuestro programa, desarrollado Escribir "Ingrese el Numero de Dias Hospitalizado";
por Pseint y el estudiante Omar"; Leer Dh;
Sino Escribir "Que tipo de Enfermedad posee segun las
Si opcion=4 Entonces opciones";
Escribir "Para encontrar el Area de un Trapecio, ingrese el Escribir "Presione 1 Fiebre Costo/Paciente/Dias = 1500";
valor de la base1"; Escribir "Presione 2 Dengue Costo/Paciente/Dias = 1700";
Leer base1; Escribir "Presione 3 Influenza Costo/Paciente/Dias =
Escribir "Ingrese ahora la base2"; 1900";
Leer base2; Leer Opcion;
Escribir "Finalmente ingrese el valor de la altura"; Segun Opcion Hacer
Areatrapecio<-(base1+base2)*altura/2; 1:
Escribir "El area de un trapecio es de:", Areatrapecio; Total<-Dh*1500;
Escribir "Gracias por usar nuestro programa, desarrollado Escribir "Paciente:", Nombre;
por Pseint y el estudiante Omar"; Escribir "Dias Hospitalizado:", Dh;
Sino Escribir "Tipo de Enfermedad:", Opcion;
Si opcion=5 Entonces Escribir "Total a Pagar", Total;
Escribir "Para hallar el valor del area de un triangulo, por 2:
favor ingrese el valor de la base"; Total<-Dh*1700;
Leer base; Escribir "Paciente:", Nombre;
Escribir "Ahora ingrese el valor de la altura"; Escribir "Dias Hospitalizado:", Dh;
Leer altura; Escribir "Tipo de Enfermedad:", Opcion;
Areatriangulo<-(base*altura)/2; Escribir "Total a Pagar", Total;
Escribir "El area del Triangulo es de:", Areatriangulo; 3:
Escribir "Gracias por usar nuestro programa, desarrollado Total<-Dh*1900;
por Pseint "; Escribir "Paciente:", Nombre;
FinSi Escribir "Dias Hospitalizado:", Dh;
FinSi Escribir "Tipo de Enfermedad:", Opcion;
FinSi Escribir "Total a Pagar:", Total;
FinSi FinSegun
FinSi Si Opcion>3 Entonces
FinProceso Escribir "Error, cierre y vuelva abrir el programa"
FinSi
Ejercicio 4.- Escribir "Desea Continuar?";
Proceso calificacion_aprobado Leer Continuar
Escribir "Bienvenido Estimado Docente"; FinMientras
Escribir "Por favor, Ingrese la Calificacion del Estudiante"; Escribir Gracias por usar Una pagina y un programa
Leer Calificacion; desarrollado por Omar Web Technology;
Si Calificacion>8 Entonces FinProceso
Escribir "El Alumno, Aprobo el Examen";
Sino Ejercicio 6.-
Escribir "El Alumno, No Aprobo el Examen"; Proceso contador
FinSi N<-0;
Escribir Gracias por usar Una pagina y un programa contador<-0;
desarrollado por Omar Web Technology; sumador<-0;
FinProceso Mientras contador<=8 Hacer
contador<-contador+2;
Ejercicio 5.- sumador<-sumador+contador;
Proceso sin_titulo FinMientras
Continuar<-"s"; Escribir "El valor de los numeros impares es:", sumador;

7
FinProceso FinProceso

Ejercicio 7.- Ejercicio 10.-


Proceso positivos_y_se_detiene_en_negativos Proceso empresa_arreglos
numero<-0; Dimension Obrero (200);
contador<-0; Escribir "Ingrese el precio del salario pagado por horas
Escribir "Ingrese el numero"; trabajadas";
Leer numero; Leer Sph;
Mientras numero>0 Hacer Escribir "ingrese la Cantidad de Obreros de su empresa";
contador<-contador+1; Leer Cant_obreros;
Escribir "Ingrese el numero"; Para i<-1 Hasta Cant_obreros Hacer
Leer numero; Escribir "Ingrese el nombre del Obrero";
FinMientras Leer Obrero (i);
Escribir "El numero es:", contador; Escribir "Ingrese la cantidad de horas trabajadas";
FinProceso Leer Ht;
Si Ht>40 y Ht<=48 Entonces
Ejercicio 8.- Tp<-Sph^2*Ht;
Proceso Vectores Escribir "El nombre del trabajador::",i;
Dimension V1(500), V2(500) Escribir " ", Obrero(i);
Escribir "Por favor ingrese la cantidad de vectores a Escribir "El precio a pagar por horas extras es de:", Tp;
almacenar" FinSi
Leer Cant_vect; Si Ht>48 Entonces
Para i<-1 Hasta Cant_vect Hacer Tp<-Sph^3*Ht;
Escribir "Ingrese el valor del vector", i; Escribir "El nombre del trabajador::",i;
Leer V1 (i); Escribir " ", Obrero(i);
FinPara Escribir "El precio a pagar por horas extras es de:", Tp;
Para i<-1 Hasta Cant_vect Hacer FinSi
V2(i)<- V1(i)^2; Si Ht<=40 Entonces
Escribir "El valor al cuadrado de la posicion:", i; Tp<-Sph*Ht;
Escribir "Es de:", V2(i); Escribir "El nombre del trabajador::",i;
Escribir "Y el valor Original es de:", V1(i); Escribir " ", Obrero(i);
FinPara Escribir "El precio a pagar es de:", Tp;
Escribir "Gracias por Usar un programa desarrollado por FinSi
Omar Landaeta"; FinPara
FinProceso Escribir "Gracias por Usar un programa desarrollado por
Omar Landaeta";
Ejercicio 9.- FinProceso
Proceso Ecuacin_d_ Segundo_grado
Escribir "Bienvenido, por favor ingrese un valor para a";
Leer a;
Escribir "Ahora ingrese un valor para b";
Leer b;
Escribir "Ingrese un valor para c";
Leer c;
J<- b^2-(4*a*c);
Si J<0 Entonces
Escribir "No procesa";
Sino
X1<- -b + RC (J)/2*a;
X2<- -b - RC (J)/2*a;
Escribir "El Valor de X1 es:", X1;
Escribir "El Valor de X2 es:", X2;
FinSi