You are on page 1of 4

Usar funcin Si en factura con varios frmulas

En la celda E14 tengo el precio venta con iva en F14 tengo esta frmula E14-G14 donde
me da el precio sin iva, en la celda G14 tengo esta frmula : =E14*0,4/100 para calcular el
4% de iva y unas lneas ms abajo para que me calcule el 21% de otros artculos, en H14
pongo el 4 de iva o el 21 segn el articulo, en I14 obtengo el iva total de multiplicar la
cantidad de artculos por el iva, para obtener el iva total de esa fila o sea esta frmula
:=B14*G14.

En J14 tengo el precio total sin iva con esta formula =F14*B14. Y en todas las celdas
excepto en cantidad y concepto las tengo en formato de moneda con dos decimales,
entonces esta todas las columnas llenas de 0,00 y quera poner con la funcin Si que me
oculte todos los 0;00 excepto en las filas donde hay datos, para no tener que borrar las
filas que no tengan datos, cada vez que haga una factura. No se si me he explicado bien
.Pongo una imagen de la factura para que la veis y si podis me ayudis por favor.
Gracias y un Saludo
Formula en el caso de das por vencer.

=SI(Y($E8<=F$4,$E8>=F$5),$D8,0)

Formula para el caso en que la factura ya venci.

=SI(Y($E8>=G$4,$E8<=G$5),$D8,0)

Podemos observar que la nica diferencia radica en que los signos >= se invierten en el
caso de la evaluacin de los das por vencer porque estn en negativo, cuando la factura
ya venci, los das.

Esto del numero en negativo y positivo se da porque al restar las fechas sucede lo
siguiente.

Si la factura aun no esta vencida, la fecha de vencimiento es mayor a la fecha actual, as


que al realizar la resta sale en negativo 8 se esta restando un numero mayor a un numero
menor.
Si la factura ya venci, naturalmente la fecha actual es mayor a la fecha de vencimiento,
as que el resultado es un numero positivo.

La funcin =SI( )

Definicin y La funcin =SI( ) es una de las ms potentes que tiene Excel. Esta funcin
sintaxis comprueba si se cumple una condicin. Si sta se cumple, da como resultado
VERDADERO. Si la condicin no se cumple, da como resultado FALSO. Obseva la
sintaxis:

=SI(Condicin;Verdadero;Falso)

Esta es la forma ms simple de representar esta funcin, porque la misma se puede


complicar que no veas. De momento vamos a proponer un ejemplo:

Observa la hoja
de la derecha.
Se trata del
ltimo ejemplo
de la leccin
anterior.
Observa que
hemos aadido
nuevas celdas y
hemos
modificado
algunas. Ahora
se trata de
colocar una
funcin =SI(
) en la
celda E15(celda
rosa del
descuento).

Ejemplo Vamos a hacer que la factura del ejemplo anterior nos haga un descuento del
10% slo en el caso de cobrar al contado. La frmula se colocar en la celda E15 y
ser la siguiente:

=SI(A17="Contado";E14*10%;0;)

Esta frmula mirar si en la casilla A17 (celda amarilla) existe la


palabra Contado. En tal caso, ejecutar una frmula (10% de descuento), en caso
contrario, colocar simplemente un cero en la celda E15, es decir, no realizar
ningn clculo. Observa el resultado: