You are on page 1of 1

/ip address

add address=192.168.1.10/24 interface=ether1


add address=192.168.2.10/24 interface=ether2
add address=192.168.3.10/24 interface=ether3
add address=192.168.10.1/24 interface=ether5

/ip dns
set allow-remote-requests=yes cache-size=5000KiB max-udp-packet-size=2048
servers=192.168.1.1,192.168.2.1,192.168.3.1

/ip firewall mangle


add chain=input in-interface=ether1 action=mark-connection new-connection-
mark=WAN1_con
add chain=input in-interface=ether2 action=mark-connection new-connection-
mark=WAN2_con
add chain=input in-interface=ether3 action=mark-connection new-connection-
mark=WAN3_con
add action=mark-routing chain=output connection-mark=WAN1_con new-routing-
mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_con new-routing-
mark=to_WAN2
add action=mark-routing chain=output connection-mark=WAN3_con new-routing-
mark=to_WAN3
add chain=prerouting dst-address=192.168.1.0/24 in-interface=ether5
add chain=prerouting dst-address=192.168.2.0/24 in-interface=ether5
add chain=prerouting dst-address=192.168.3.0/24 in-interface=ether5
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth
in-interface=ether5 new-connection-mark=WAN1_con per-connection-classifier=both-
addresses-and-ports:3/1
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth
in-interface=ether5 new-connection-mark=WAN2_con per-connection-classifier=both-
addresses-and-ports:3/2
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth
in-interface=ether5 new-connection-mark=WAN3_con per-connection-classifier=both-
addresses-and-ports:3/3
add action=mark-routing chain=prerouting connection-mark=WAN1_con in-
interface=ether5 new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_con in-
interface=ether5 new-routing-mark=to_WAN2
add action=mark-routing chain=prerouting connection-mark=WAN3_con in-
interface=ether5 new-routing-mark=to_WAN3

/ip firewall nat


add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2
add action=masquerade chain=srcnat out-interface=ether3

/ip route
add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=192.168.3.1 routing-mark=to_WAN3
add check-gateway=ping distance=1 gateway=192.168.1.1
add check-gateway=ping distance=2 gateway=192.168.2.1
add check-gateway=ping distance=3 gateway=192.168.3.1

You might also like