You are on page 1of 8

R4

==========================================
enable
conf t
interface serial 0/0/0
ip add 10.0.0.13 255.255.255.252
no shut
exit

interface serial 0/0/1


ip add 10.0.0.10 255.255.255.252
no shut
exit

interface serial 0/1/0


ip add 10.0.0.21 255.255.255.252
no shut
exit

router ospf 1
log-adjacency-changes
network 10.0.0.8 0.0.0.3 area 0
network 10.0.0.12 0.0.0.3 area 0
network 4.4.4.4 0.0.0.0 area 0
end
wr

default-information originate

R5
==========================================
enable
conf t
int lo0
ip add 5.5.5.5 255.255.255.255
exit
int s0/0/0
ip add 10.0.0.2 255.255.255.252
no shut
exit
int s0/0/1
ip add 10.0.0.5 255.255.255.252
no shut
exit
int s0/1/0
ip add 10.0.0.9 255.255.255.252
no shut
exit
router ospf 1
network 10.0.0.4 0.0.0.3 area 0
network 10.0.0.8 0.0.0.3 area 0
default-information originate
end
wr

R6
==========================================
enable
conf t
int lo0
ip add 6.6.6.6 255.255.255.255
exit
int s0/0/0
ip add 10.0.0.6 255.255.255.252
no shut
exit
int s0/0/1
ip add 10.0.0.17 255.255.255.252
no shut
exit
int s0/1/0
ip add 10.0.0.14 255.255.255.252
no shut
exit
router ospf 1
router-id 6.6.6.6
log-adjacency-changes
network 10.0.0.0 0.0.0.3 area 0
network 6.6.6.6 0.0.0.0 area 0
end
wr
show ip ospf neighbor
show ip route

R1
==========================================
enable
conf t
int lo0
ip add 1.1.1.1 255.255.255.255
exit
int s0/0/0
ip add 10.0.0.1 255.255.255.252
crypto map R0_Map
no shut
exit
ip route 0.0.0.0 0.0.0.0 10.0.0.2

interface tunnel 0
ip add 192.168.0.1 255.255.255.252
tunnel source serial 0/0/0
tunnel destination 10.0.0.18
tunnel mode gre ip
exit

int fa0/0
no shut
exit

interf fa0/0.12
encapsulation dot1Q 12
ip add 192.168.12.1 255.255.255.0
no shut
exit
interf fa0/0.13
encapsulation dot1Q 13
ip add 192.168.13.1 255.255.255.0
no shut
exit

ip dhcp excluded-address 192.168.12.1


ip dhcp excluded-address 192.168.13.1

ip dhcp pool voz1


network 192.168.12.0 255.255.255.0
default-router 192.168.12.1
option 150 ip 192.168.12.1
exit

ip dhcp pool datos1


network 192.168.13.0 255.255.255.0
default-router 192.168.13.1
option 150 ip 192.168.13.1
exit

telephony-service
max-dn 2
max-ephones 2
ip source-add 192.168.12.1 port 2000
auto assign 1 to 2
ephone-dn 1
number 1001

ephone-dn 2
number 1002
exit

acces-list 101 permit ip 192.168.12.0 0.0.0.255 192.168.10.0 0.0.0.255


crypto isakmp policy 101
encryption aes
authentication pre-share
group 5
exit
cryto isakmp key cisco add 10.0.0.18
crypto ipsec transform-set R0_Set esp-aes esp-sha-hmac
crypto map R0_Map 101 ipsec-isakmp
set peer 10.0.0.18
set transform-set R0_Set
match add 101
exit

dial-peer voice 1 voip


destination-pattern 200.
session target ipv4: 192.168.0.2
exit
end
wr

sw1
=======================================
enable
vlan database
vlan 13 name datos
vlan 12 name VOZ
exit
conf t
interf range fa0/1
switchport mode access
switchport voice vlan 12
spanning-tree portfast
exit

interf range fa0/2


switchport mode access
switchport access vlan 13
switchport voice vlan 12
spanning-tree portfast
exit

interf fa0/24
switchport mode trunk
switchport trunk allowed vlan 12-13
end
wr

R2
==========================================
enable
conf t
int lo0
ip add 2.2.2.2 255.255.255.255
exit
int s0/0/0
ip add 10.0.0.18 255.255.255.252
no shut
exit
ip route 0.0.0.0 0.0.0.0 10.0.0.17

interface tunnel 0
ip add 192.168.0.2 255.255.255.252
tunnel source serial 0/0/0
tunnel destination 10.0.0.1
tunnel mode gre ip
exit

int fa0/0
no shut
exit

interf fa0/0.10
encapsulation dot1Q 10
ip add 192.168.10.1 255.255.255.0
no shut
exit
interf fa0/0.11
encapsulation dot1Q 11
ip add 192.168.11.1 255.255.255.0
no shut
exit

ip dhcp excluded-address 192.168.10.1


ip dhcp excluded-address 192.168.11.1

ip dhcp pool voz2


network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
option 150 ip 192.168.10.1
exit

ip dhcp pool datos2


network 192.168.11.0 255.255.255.0
default-router 192.168.11.1
option 150 ip 192.168.11.1
exit

telephony-service
max-dn 2
max-ephones 2
ip source-add 192.168.10.1 port 2000
auto assign 1 to 2
ephone-dn 1
number 2001
exit
ephone-dn 2
number 2002
exit

acces-list 101 permit ip 192.168.10.0 0.0.0.255 192.168.12.0 0.0.0.255


crypto isakmp policy 101
encryption aes
authentication pre-share
group 5
exit

crypto isakmp key cisco add 10.0.0.1


crypto ipsec transform-set R2_Set esp-aes esp-sha-hmac
crypto map R2_Map 101 ipsec-isakmp
set peer 10.0.0.18
set transform-set R2_Set
match add 101
exit

interface tunnel 1
ip add 172.16.0.2 255.255.255.252
tunnel source serial 0/0/0
tunnel destination 10.0.0.22
tunnel mode gre ip
exit

acces-list 102 permit ip 192.168.10.0 0.0.0.255 192.168.14.0 0.0.0.255


crypto isakmp policy 102
encryption aes
authentication pre-share
group 5
exit

crypto isakmp key cisco add 10.0.0.22


crypto ipsec transform-set R3_Set esp-aes esp-sha-hmac
crypto map R2_Map 101 ipsec-isakmp
set peer 10.0.0.18
set transform-set R3_Set
match add 101
exit

dial-peer voice 1 voip


destination-pattern 100.
session target ipv4: 172.16.0.1
exit

^z
wr

sw2
=======================================
enable
vlan database
vlan 10 name voz2
vlan 11 name datos2
exit
wr
conf t
interf range fa0/1
switchport mode access
switchport access vlan 11
switchport voice vlan 10
spanning-tree portfast
exit

interf range fa0/2


switchport mode access
switchport access vlan 13
switchport voice vlan 12
spanning-tree portfast
exit

interf fa0/24
switchport mode trunk
switchport trunk allowed vlan 12-13
end
wr

R3
==========================================
enable
conf t
int lo0
ip add 3.3.3.3 255.255.255.255
exit
int s0/0/0
ip add 10.0.0.22 255.255.255.252
no shut
exit
ip route 0.0.0.0 0.0.0.0 10.0.0.21

interface tunnel 1
ip add 172.16.0.1 255.255.255.252
tunnel source serial 0/0/0
tunnel destination 10.0.0.14
tunnel mode gre ip
exit
int fa0/0
no shut
exit

interf fa0/0.14
encapsulation dot1Q 10
ip add 192.168.14.1 255.255.255.0
no shut
exit
interf fa0/0.15
encapsulation dot1Q 11
ip add 192.168.15.1 255.255.255.0
no shut
exit

ip dhcp excluded-address 192.168.14.1


ip dhcp excluded-address 192.168.15.1

ip dhcp pool voz3


network 192.168.14.0 255.255.255.0
default-router 192.168.14.1
option 150 ip 192.168.14.1
exit

ip dhcp pool datos3


network 192.168.15.0 255.255.255.0
default-router 192.168.15.1
option 150 ip 192.168.15.1
exit

telephony-service
max-dn 4
max-ephones 4
ip source-add 192.168.10.1 port 2000
auto assign 1 to 4
ephone-dn 1
number 3001
exit
ephone-dn 2
number 3002
exit
ephone-dn 3
number 3003
exit
ephone-dn 4
number 3004
exit

acces-list 101 permit ip 192.168.10.0 0.0.0.255 192.168.14.0 0.0.0.255


crypto isakmp policy 101
encryption aes
authentication pre-share
group 5
exit

crypto isakmp key cisco add 10.0.0.18


crypto ipsec transform-set R2_Set esp-aes esp-sha-hmac
crypto map R2_Map 101 ipsec-isakmp
set peer 10.0.0.22
set transform-set R2_Set
match add 101
exit

dial-peer voice 1 voip


destination-pattern 100.
session target ipv4: 172.16.0.2
exit

^z
wr

sw3
=======================================
enable
vlan database
vlan 14 name voz2
vlan 15 name datos2
exit
wr
conf t
interf range fa0/1-fa0/4
switchport mode access
switchport access vlan 14
switchport voice vlan 15
spanning-tree portfast
exit

interf range fa0/2-fa0/4


switchport mode access
switchport access vlan 14
switchport voice vlan 15
spanning-tree portfast
exit

interf fa0/24
switchport mode trunk
switchport trunk allowed vlan 14-15
end
wr

You might also like