You are on page 1of 3

Laboratoare PPP – v 0.

LAB 1 : (fara autentificare)


R1(config)#interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ip address 10.0.0.1 255.255.255.0
R1(config-if)# no shutdown

R2(config)#interface s2/0
R2(config-if)# encapsulation ppp
R2(config-if)# ip address 10.0.0.2 255.255.255.0
R2(config-if)# no shutdown

LAB 2 : (cu autentificare PAP unidirectionala; R1 este autentificator, R2 este peer)


R1(config)#interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ppp authentication pap
R1(config-if)# ip address 10.0.0.1 255.255.255.0
R1(config-if)# no shutdown
R1(config)# username R2-user password R2-password

R2(config)#interface s2/0
R2(config-if)# encapsulation ppp
R2(config-if)# ppp pap sent-username R2-user password R2-password
R2(config-if)# ip address 10.0.0.2 255.255.255.0
R2(config-if)# no shutdown

LAB 3 : (cu autentificare CHAP unidirectionala; R1 este autentificator, R2 este peer)


R1(config)#interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ppp authentication chap
R1(config-if)# ip address 10.0.0.1 255.255.255.0
R1(config-if)# no shutdown
R1(config)# username R2-user password password-comun

R2(config)#interface s2/0
R2(config-if)# encapsulation ppp
R2(config-if)# ppp chap hostname R2-user
R2(config-if)# ip address 10.0.0.2 255.255.255.0
R2(config-if)# no shutdown
R2(config)# username R1 password password-comun
LAB 4 : (fara autentificare, cu alocare de adresa IP vecinului, si de ruta default)
R1(config)#interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ip address negotiated
R1(config-if)# ppp ipcp route default
R1(config-if)# no shutdown

R2(config)#interface s2/0
R2(config-if)# encapsulation ppp
R2(config-if)# ip address 10.0.0.2 255.255.255.0
R2(config-if)# peer default ip address 10.0.0.1
R2(config-if)# no shutdown

LAB 5 : (compresie headere IP+TCP / IP+UDP+RTP / payload date)


R1(config)#interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ip tcp header-compression
R1(config-if)# ip rtp header-compression
R1(config-if)# compress {predictor|stac|mppc}
R1(config-if)# ip address 10.0.0.1 255.255.255.0
R1(config-if)# no shutdown

R2(config)#interface s2/0
R2(config-if)# encapsulation ppp
R1(config-if)# ip tcp header-compression
R1(config-if)# ip rtp header-compression
R1(config-if)# compress {predictor|stac|mppc}
R2(config-if)# ip address 10.0.0.2 255.255.255.0
R2(config-if)# no shutdown

LAB 6 : (cu autentificare EAP unidirectionala; R1 este autentificator, R2 este peer)


R1(config)#interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ppp authentication eap
R1(config-if)# ppp eap local
R1(config-if)# ip address 10.0.0.1 255.255.255.0
R1(config-if)# no shutdown
R1(config)# username R2-user password password-comun

R2(config)#interface s2/0
R2(config-if)# encapsulation ppp
R2(config-if)# ppp eap identity R2-user
R2(config-if)# ppp eap password password-comun
R2(config-if)# ip address 10.0.0.2 255.255.255.0
R2(config-if)# no shutdown

LAB 7 : (compresia campului de adresa&control, cat si a celui de protocol)


R1(config)#interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ppp acfc local request  Address and Control Field Compression
R1(config-if)# ppp acfc remote apply  Protocol Field Compression
R1(config-if)# ppp pfc local request
R1(config-if)# ppp pfc remote apply
R1(config-if)# ip address 10.0.0.1 255.255.255.0
R1(config-if)# no shutdown

R2(config)#interface s2/0
R2(config-if)# encapsulation ppp
R1(config-if)# ppp acfc local request
R1(config-if)# ppp acfc remote apply
R1(config-if)# ppp pfc local request
R1(config-if)# ppp pfc remote apply
R2(config-if)# ip address 10.0.0.2 255.255.255.0
R2(config-if)# no shutdown

LAB 8 : (multilink PPP)

R1(config)#interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ppp multilink group 11
R1(config-if)# no shutdown

R1(config)#interface s3/0
R1(config-if)# encapsulation ppp
R1(config-if)# ppp multilink group 11
R1(config-if)# no shutdown

R1(config)# interface multilink 11


R1(config-if)# ip address 10.0.0.1 255.0.0.0

R2(config)#interface s2/0
R2(config-if)# encapsulation ppp
R2(config-if)# ppp multilink group 22
R2(config-if)# no shutdown

R2(config)#interface s3/0
R2(config-if)# encapsulation ppp
R2(config-if)# ppp multilink group 22
R2(config-if)# no shutdown

R2(config)# interface multilink 22


R2(config-if)# ip address 10.0.0.2 255.0.0.0

You might also like