You are on page 1of 104

Please wait, CIS 185 will begin shortly (5:30pm)

There will be no sound until class begins. I will do


a sound check at the beginning of class.

CIS 185 CCNP ROUTE


EIGRP Part 1
Rick Graziani
Cabrillo College
graziani@cabrillo.edu
Last Updated: Fall 2010

EIGRP Part 1
Review
Neighbor Adjacencies and
EIGRP Reliability
EIGRP Metric
DUAL
Basic EIGRP Configuration
Passive-Interfaces
Summarization
Default Route

Materials
Book:
Implementing Cisco IP Routing
(ROUTE) Foundation Learning
Guide: Foundation learning for the
ROUTE 642-902 Exam
By Diane Teare
Book
ISBN-10: 1-58705-882-0
ISBN-13: 978-1-58705-882-0
eBook
ISBN-10: 0-13-255033-4
ISBN-13: 978-0-13-255033-8

Review

What do we remember about EIGRP?


What type of protocol is EIGRP?
Distance Vector
What are the default metrics used by EIGRP?
Bandwidth (slowest) and Delay (cumulative)
What are the optional metrics?
Reliability and Load
Note: Book also state MTU but it is not a metric.
What algorithm is used to determine best path?
DUAL (Diffusing Update Algorithm)

Review of EIGRP from CCNA

Enhanced Interior Gateway Routing Protocol (EIGRP)


Released in 1992 with Cisco IOS Software Release 9.21.
Enhancement of Ciscos:
Interior Gateway Routing Protocol (IGRP).
Both are Cisco proprietary, operate only on:
Cisco routers
7

RTP and EIGRP


Packet Types

What transport layer protocol does EIGRP use?


Reliable Transport Protocol (RTP)
Why doesnt EIGRP use UDP or TCP?

ProtocolDependent
Modules

EIGRP uses protocol-dependent modules (PDM). to route


different protocols, including:
IPv4
IPv6
Internetwork Packet Exchange (IPX)
AppleTalk

EIGRP Packet
Types Hello
Packet

What are Hello packets used for by EIGRP to:


Discover neighbors (sometimes called neighborships)
Form adjacencies with those neighbors
What is the multicast address? Hint: 224.0.0.?
224.0.0.10
Are these sent as reliable or unreliable deliver?
Unreliable delivery No ACKs returned
10

Hello Protocol

NBMA Link that are

All other serial interfaces and


LANs

11

Hello Protocol

NBMA Link that are

All other serial interfaces and


LANs

Default hold time - 3 times the hello interval


If the hold time expires:
EIGRP declares the route as down
DUAL searches for a new path in the topology table or by
sending out queries.
It is NOT automatically adjusted if Hello Interval is modified.

12

EIGRP Packet Types


Update and
Acknowledgement
Packets
EIGRP uses
triggered
updates

Update Packets Reliable Delivery


Acknowledgment (ACK) Packets Unreliable Delivery
Sent when reliable delivery is used (update, query, and reply
packets).

13

EIGRP Packet
Types Query
and Reply
Packets

Queries and replies use reliable delivery (Ack returned).


Used by DUAL when searching for networks and other tasks.

14

DUAL: An Introduction

J. J. Garcia-Luna-Aceves

15

DUAL: An Introduction (More later!)


R2: Checks
Topology table for
Feasible
Successor. If no
FS

Or holdtime expires

.
16

Summary - RTP Packet Types


Hellos Identifies neighbors
Used by the neighbor discovery and recovery process.
Multicast
Unreliable delivery
Acknowledgements (ACK) Acknowledges receipt
Hello packets with no data
Unicast
Unreliable delivery
Updates Advertises routes
Transmitted only when necessary
Unicast when sent to a specific router
Multicast when sent to multiple routers
Reliable delivery
Queries Ask about a route (DUAL)
Reliable delivery
Multicast or Unicast
Queries and Replies Ask about a route and answer a query (DUAL)
Reliable delivery
Replies: Unicast

17

Administrative Distance
We will discuss Administrative
Distance in more detail in a
later chapter.
Later in this chapter, you
learn how to configure EIGRP
summary routes.

18

Neighbor Adjacencies and


EIGRP Reliability

19

Configuring Hello Intervals and Hold Times

Router(config-if)# ip hello-interval eigrp as-number seconds


Router(config-if)# ip hold-time eigrp as-number seconds

Configurable on a per-interface basis, NOT per neighbor (LANs)


Does not have to match with other EIGRP routers to establish
adjacencies.

20

Neighbor Table Contents

H (handle) Internal number used by the Cisco IOS.


Order in which a neighboring (peering) session was established
Starts with 0.
AddressThe neighbors IP address.
InterfaceThe outgoing interface on this router receiving hello packets for
the neighbor.
Hold TimeThe maximum time, in seconds, that the router waits to hear
from the neighbor without receiving anything from a neighbor before
considering the link unavailable.
Originally, had to be a hello packet, but in current Cisco IOS any EIGRP
packet received after the first hello from that neighbor resets the timer.
UptimeTime, in HH:MM:SS since the router first heard from this neighbor.

21

Start

Neighbor Table Contents

Smooth Round Trip Timer (SRTT)The


average number of milliseconds it takes for an
EIGRP packet to be sent to this neighbor and
for the local router to receive an
acknowledgment of that packet.
Used to determine the retransmit interval,
a.k.a. retransmit timeout (RTO).
RTOThe amount of time, in milliseconds, that
the router waits for an acknowledgment before
retransmitting a reliable packet from the
retransmission queue to a neighbor.

Stop

Start
Stop

No ACK Returned

22

Neighbor Table Contents

Queue countThe number of EIGRP packets (update, query, and reply) waiting
in the queue to be sent out.
If this value is constantly higher than 0, a congestion problem might exist.
0 = no EIGRP packets in the queue.
Seq NumThe sequence number of the last update, query, or reply packet that
was received from this neighbor.
A sequence number is assigned to each reliable packet.
An explicit ACK is required for that sequence number.

23

Start

EIGRP Reliability
RTOThe amount of time, in milliseconds, that the
router waits for an acknowledgment before
retransmitting a reliable packet from the
retransmission queue to a neighbor.
Updates, queries and replies are sent reliably.
A sequence number is assigned and an explicit ACK
is returned for each sequence number.

Stop

No ACK Returned

16 x RTO < Hold Timer


If the RTO expires before and ACK is received, EIGRP retransmits another copy of
the packet.
A maximum of 16 times OR until the hold time expires then the Neighbor is
declared down.
When a neighbor is declared down:
The adjacency is removed
All networks reached through that neighbor are removed from the routing table.
180 second hold time on low-speed NBMA links can be a long time to wait.
Retransmission occurs after each RTO timer expires.
After 16 attempts the neighbor is declared down.
24
This is less time than waiting for the hold time to expire.

EIGRP Reliability
Update 100
Update 101
(in queue)
Multicast Flow
Timer expires

e101
t
a
d
Up

ACK

Upda
No A te100
CK R
eceiv
ed

R3#Potential
show ip problem
eigrp interfaces

on multiaccess (Frame Relay, Ethernet) media where


IP-EIGRP
process 1
multipleinterfaces
neighbors for
reside.
The next reliable multicast packet cannot be sent until all peers have
Xmit Queue
Mean
Pacing Time
Multicast
Pending
Acknowledged
the
previous
multicast
packet.
Interface
Peers Un/Reliable SRTT
Un/Reliable
Flow Timer
Routes
If one or 1more neighbors
are slow
Se0/1
0/0
60 to respond
0/15 it adversely
299 affects all peers.
0
Se0/0
1
0/0to respond
607to multicasts
0/15 or does3031
0 the

When a neighbor
is slow
not acknowledge
R3#multicast, the router will retransmit the packet as a unicast.
This allows reliable multicasts to continue and speeds up convergence without
waiting for peers on lower speed links.
Multicast flow timer - Determines how long a router should wait for an ACK to
be received before switching from multicast to unicast.
Calculation is based on RTO and SRTT (Cisco proprietary)

25

Neighbor Table Contents


R3# show ip eigrp neighbors detail
IP-EIGRP neighbors for process 1
H
Address
Interface
3
2

10.0.0.18
Version 12.3/1.2,
10.0.0.14
Version 12.3/1.2,
10.0.0.5
Version 12.3/1.2,
10.0.0.9
Version 12.3/1.2,

1
0

Hold Uptime
SRTT
(sec)
(ms)
Se0/3
13 01:03:55
24
Retrans: 2, Retries: 0
Se0/2
14 01:04:08
29
Retrans: 1, Retries: 0
Se0/0
13 01:09:52 607
Retrans: 0, Retries: 0
Se0/1
12 01:10:19
60
Retrans: 0, Retries: 0

RTO

Q Seq Type
Cnt Num
200 0 5
200

3642

13

360

21

R3#

The show ip eigrp interfaces detail command displays a router's


EIGRP Hello timer setting for each enabled interface.
26

Initial Route Discovery


A

B
Updated

Updated
EIGRP
Neighbor
Table

Hello, I am Router A. Is anyone there?

EIGRP
Neighbor
Table

Hello, I am Router B.

Updated
EIGRP
Topology
Table

Here is all my routing information.


Im using split horizon.

Thanks for the information!


That is very nice of you.

Successor

Updated
IP
Routing
Table

Updated
EIGRP
Topology
Table
Successor

Here is all my routing information.


Im also using split horizon.
Thanks for the information!
Weve reached convergence.

Updated
IP
Routing
Table

27

Router-ID
Router(config)# router eigrp as
Router(config-router)# router-id ip-address
EIGRP Router ID is an IP address used to uniquely identify an
EIGRP router.
1. Use the IP address configured with the EIGRP router-id
command.
2. Highest IP address of any of its loopback interfaces.
3. Highest active IP address of any of its physical interfaces.

28

Forming Neighbor Adjacencies


Per interface/subinterface not per neighbor
The following are the most common causes of problems with EIGRP
neighbor relationships:
Unidirectional link
Uncommon subnet, primary, and secondary address mismatch
Mismatched masks
K value mismatches
Mismatched AS numbers
Stuck in active
Layer 2 problem
Access list denying multicast packets
Manual change (summary router, metric change, route filter)
Does NOT prevent neighbor relationships
Hello and Hold timer setting mismatch
Duplicate router IDs
IP MTU mismatch

29

The Metric

Metric

By default, K1 and K3 are set to 1, and K2, K4, and K5 are set to 0.
The result is that only the bandwidth and delay values are used in
the computation of the default composite metric.
Reliability and Load are optional metrics.
MTU is NOT a metric, never has been, never will be.
31

Metric
R1# show ip protocols
Routing Protocol is eigrp 1
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
<output omitted>

K1

K2

K3

K4

K5

The K values on R1 are set to the default.


Changing these values to other than the default is not recommended
unless the network administrator has a very good reason to do so.
Cisco recommends that these values are not modified.

32

Metric: Displaying Interface Values


SanJose2> show interface s0/0
Serial0/0 is up, line protocol is up
Hardware is QUICC Serial
Description: Out to Westasman
Internet address is 192.168.64.5/30
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
rely 255/255, load 246/255
<output omitted>

EIGRP bandwidth uses the minimum bandwidth link represented in


107 divided by the kilobits per second.
Show interfaces displays bandwidth in kilobits per second.
EIGRP delay value is the sum of delays in tens of microseconds
multiplied by 256.
Show interfaces displays delay in microseconds.

Metric Calculation

For a review and examples of how the EIGRP metric is calculate


read Chapter 2 EIGRP, EIGRP Metric Calculation or review my
CIS 82 PowerPoint presentations on EIGRP.

34

DUAL

DUAL Concepts
Diffusing Update Algorithm is the algorithm used by
EIGRP.
Determines:
best loop-free path
loop-free backup paths (which can be used immediately)
DUAL also provides the following:
Fast convergence
Minimum bandwidth usage with bounded updates
DUAL uses several terms that are discussed in more detail
throughout this section:
Successor
Feasible distance
Feasible successor
Reported distance or advertised distance
Feasible condition or feasibility condition
36

Successors and Feasible Successors


Feasible distance (FD) is the minimum distance (metric) along a path to a
destination network.
Reported distance (RD or AD) is the distance (metric) towards a destination as
advertised by an upstream neighbor. Reported distance is the distance reported
in the queries, the replies and the updates.
A neighbor meets the feasible condition (FC) if the reported distance by the
neighbor is less than the current feasible distance (FD) of this router. "If a
neighbors metric is less than mine, then I know the neighbor doesn't have a loop
going through me."
A feasible successor is a neighbor whose reported distance (RD) is less than the
current feasible distance (FD). Feasible successor is one who meets the feasible
condition (FC).
Your route (metric) to the network (RD to me) must be LESS than my current route
(my total metric) to that same network. If your route (metric) to the network (RD to
me) is LESS than my current route (my total metric), I will include you as a
FEASIBLE SUCCESSOR.
If your route (metric) to the network (RD to me) is MORE than my current route (my
37
total metric), I will NOT include you as a FEASIBLE SUCCESSOR.

Example 1: Best Path (Successor)? Feasible Successor?


RD = 6,000,000
R2

FD = 6,500,000

Which router is
the successor?
Network X

R1

S0/0
S0/1

FD = 3,500,000
R3
RD = 3,000,000

FD = RD + additional Delay of serial link between R1 and neighbor.


(This could also be due the slowest bandwidth.)
38

Example 1
RD = 6,000,000
R2

FD = 6,500,000

Is R2 a feasible
successor?
Network X

R1

S0/0
S0/1

FD = 3,500,000
R3

Successor

RD = 3,000,000

FD of 3,500,000 is the metric for network X in the routing table for


R1.
39

Example 1
RD = 6,000,000

NOT a Feasible
Successor

R2

FD = 6,500,000

Network X
R1

S0/0
S0/1

FD = 3,500,000
R3

Successor

RD = 3,000,000

RD of R2 is greater than FD through R3.


Does not meet FC.
No FS.

40

Example 1
RX

RD = 6,000,000
R2

NOT a Feasible
Successor
Network X

R1

S0/0
S0/1

R3

Successor

RD = 3,000,000

Maybe R2s path to Network X includes R1 - Loop


41

Example 1
RD = 6,000,000
R2

R1

S0/0

RX

NOT a Feasible
Successor
Network X

S0/1

R3

Successor

RD = 3,000,000

Or maybe R2s does have a valid path to Network X.


But R1 cant tell because the distance vector update only gives it
distance and direction.

42

Example 2: Best Path (Successor)? Feasible Successor?


RD = 4,000,000
R2

FD = 5,500,000

Feasible
Successor?
Network X

R1

S0/0
S0/1

FD = 4,500,000
R3

Successor

RD = 3,000,000

FD = RD + additional Delay of serial link between R1 and neighbor.


(This could also be due the slowest bandwidth.)
43

Example 2
RD = 4,000,000
R2

FD = 5,500,000

Feasible
Successor
Network X

R1

S0/0
S0/1

FD = 4,500,000
R3

Successor

RD = 3,000,000

RD of R2 is less than (or equal to) the FD through R3.


Meets FC, there is no loop back through R1.
Is a FS.

44

Query and Reply Packets


Queries

RtrD

RtrB

Replies

RtrE

RtrA

X
RtrF

RtrC
RtrG

Looking for new route


If there are no Feasible Successors, the router must ask neighbors for help in hope of
finding a new, loop-free path to the destination.
Neighbor routers are compelled to reply to this query.
If a neighbor has a route, it will reply with information about the successor(s).
If not, the neighbor notifies the sender that it doesnt have a route to the destination
either.

45

Step 1

10.1.1.0/24

A
(1)
(1)

D
(2)

(2)

(1)

(1)

The topology

46

Step 2

10.1.1.0/24

A
(1)

(1)

D
(2)

(2)

(1)

(1)

Successor
Feasible Successor (AD is less than FD)

47

Step 3

10.1.1.0/24

Unusable

(1)
Successor still
via Router A

Unreachable
B
(2)

(2)

Successor still
via Router B

(1)

(1)

Unusable

Router D: Sets the metric to network 10.1.1.0/24 as unreachable (1 is unreachable).


No FS (Feasible Successor) in the topology table, so the route changes from the passive
state to the Active state.
Active state: Router sends out queries to neighboring routers looking for a new successor.
Sends a query to Routers C and E for an alternative path to network 10.1.1.0/24.
Marks Routers C and E as having a query pending (q).
Router E: DUAL marks the path to network 10.1.1.0/24 through Router D as Unusable.
Router C: DUAL marks the path to network 10.1.1.0/24 through Router D as Unusable. 48

Step 4

10.1.1.0/24

A
Unusable

(1)
Successor still
via Router A

D
(2)

(2)

(1)

R
Successor still
via Router B

(1)

Unusable

Router D: DUAL receives a reply from Router C indicating no change to the path to 10.1.1.0/24
DUAL removes the query pending flag from Router C.
DUAL stays Active on network 10.1.1.0/24, awaiting a reply from Router E to its query (q).
Router E: there is no FS to network 10.1.1.0/24, because the AD from Router C (3) is not less
than the original FD (also 3).
DUAL generates a query to Router C.
DUAL marks Router C as query pending (q).
49
Router C: DUAL marks the path to network 10.1.1.0/24 through Router E as Unusable.

Step 5

10.1.1.0/24

A
(1)
Successor still
via Router A

D
(2)

(2)

Successor still
via Router B

(1)

(1)

Converged

Router D: DUAL stays active on network 10.1.1.0/24, awaiting a reply from Router E (q).
Router E: DUAL receives a reply from Router C indicating no change.
It removes the query flag from Router C.
It calculates a new FD and installs a new successor route in the topology table.
It changes the route to network 10.1.1.0/24 from Active to Passive (converged).
50

Step 6

10.1.1.0/24

A
(1)
Successor still
via Router A

Converged
B

D
(2)

(2)

(1)

R
Successor still
via Router B

(1)

Converged

Router D: DUAL receives a reply from Router E.


It removes the query flag from Router E.
It calculates a new FD.
It installs new successor routes in the topology table.
Two routes (through Routers C and E) have the same FD, and both are marked as
successors.
It changes the route to network 10.1.1.0/24 from Active to Passive (converged).
51

Step 7

10.1.1.0/24

A
(1)
Successor still
via Router A

B
(2)

(2)

Successor still
via Router B

(1)

(1)

Router D: Two successor routes are in the topology table for network 10.1.1.0/24.
Both successor routes are listed in the routing table, and equal-cost load balancing is in
effect.
The network is stable and converged.
Successor
No Feasible Successors

52

Basic EIGRP Configuration

Our Topology

54

Preconfigs

R1(config)# no ip domain lookup


R1(config)# line con 0
R1(config-line)# exec-timeout 0 0
R1(config-line)# logging synchronous

Configured on all routers.


55

R1

interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
!
interface Serial0/0
bandwidth 1544
ip address 10.0.0.1 255.255.255.252
clock rate 64000
!
interface Serial0/1
bandwidth 1544
ip address 10.0.0.5 255.255.255.252

Bandwidth of 1,424 Kbps (1,424,000 bps) between R3 and R4 on


bottom link
1544 configured on all serial links just in case.

56

R2

interface FastEthernet0/0
ip address 192.168.20.1 255.255.255.0
!
interface Serial0/0
bandwidth 1544
ip address 10.0.0.2 255.255.255.252
!
interface Serial0/1
bandwidth 1544
ip address 10.0.0.9 255.255.255.252
clock rate 64000

57

R3
interface FastEthernet0/0
ip address 192.168.30.1 255.255.255.0
!
interface Serial0/0
bandwidth 1544
ip address 10.0.0.6 255.255.255.252
clockrate 64000
!
interface Serial0/1
bandwidth 1544
ip address 10.0.0.10 255.255.255.252
!
interface Serial0/2
bandwidth 1544
ip address 10.0.0.13 255.255.255.252
clockrate 64000
!
interface Serial0/3
bandwidth 1424
ip address 10.0.0.17 255.255.255.252
clockrate 64000

58

R4

interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0
bandwidth 1544
ip address 10.0.0.14 255.255.255.252
!
interface FastEthernet0/1
ip address 172.16.2.1 255.255.255.0
!
interface Serial0/1
bandwidth 1424
ip address 10.0.0.18 255.255.255.252
59

Configuring
EIGRP R1

R1(config)# router
R1(config-router)#
R1(config-router)#
R1(config-router)#

eigrp 1
network 10.0.0.0 0.0.0.3
network 10.0.0.4 0.0.0.3
network 192.168.10.0

Wildcard masks Specifically tells EIGRP which interfaces to be


enabled on.
If subnet mask is used IOS may convert it for the running-config.
Lets do R2, R3 and R4 serial interfaces with wildcard masks
60

Configuring
EIGRP
R2(config)# router
R2(config-router)#
R2(config-router)#
R2(config-router)#

eigrp 1
network 10.0.0.0 0.0.0.3
network 10.0.0.8 0.0.0.3
network 192.168.20.0

R3(config)# router
R3(config-router)#
R3(config-router)#
R3(config-router)#
R3(config-router)#
R3(config-router)#

eigrp 1
network
network
network
network
network

R4(config)# router
R4(config-router)#
R4(config-router)#
R4(config-router)#

eigrp 1
network 10.0.0.12 0.0.0.3
network 10.0.0.16 0.0.0.3
network 172.16.0.0

10.0.0.4 0.0.0.3
10.0.0.8 0.0.0.3
10.0.0.12 0.0.0.3
10.0.0.16 0.0.0.3
192.168.30.0

61

Outputs

R3# show ip route


C
D
D
D
C
C
D
C
C

192.168.30.0/24 is directly connected, FastEthernet0/0


192.168.10.0/24 [90/2172416] via 10.0.0.5, 00:02:47, Serial0/0
172.16.0.0/16 [90/2172416] via 10.0.0.14, 00:02:39, Serial0/2
192.168.20.0/24 [90/2172416] via 10.0.0.9, 00:17:22, Serial0/1
10.0.0.0/30 is subnetted, 5 subnets
10.0.0.8 is directly connected, Serial0/1
10.0.0.12 is directly connected, Serial0/2
10.0.0.0 [90/2681856] via 10.0.0.5, 00:02:57, Serial0/0
[90/2681856] via 10.0.0.9, 00:02:57, Serial0/1
10.0.0.4 is directly connected, Serial0/0
10.0.0.16 is directly connected, Serial0/3

Why does R3 prefer the top link to 172.16.0.0?


It is 1,544 kbps link compared to 1,424 kbps link below
What do you notice aobut the 10.0.0.0 network? How many paths?
R3 has equal cost paths to 10.0.0.0/30

62

Outputs

R3# show ip eigrp neighbors


IP-EIGRP neighbors for process 1
H
Address
Interface
Type
3
2
1
0
R3#

10.0.0.18
10.0.0.14
10.0.0.5
10.0.0.9

Se0/3
Se0/2
Se0/0
Se0/1

Hold Uptime

SRTT

(sec)
(ms)
13 00:17:37
24
14 00:17:50
29
14 00:23:35 607
12 00:24:01
60

Does R3 see R4 as a neighbor on both links?


Yes

RTO

Seq

200
200
3642
360

Cnt
0
0
0
0

Num
5
4
13
21

63

Outputs

R3# show ip eigrp neighbors detail


IP-EIGRP neighbors for process 1
H
Address
Interface
3
2

10.0.0.18
Version 12.3/1.2,
10.0.0.14
Version 12.3/1.2,
10.0.0.5
Version 12.3/1.2,
10.0.0.9
Version 12.3/1.2,

1
0

Hold Uptime
SRTT
(sec)
(ms)
Se0/3
13 01:03:55
24
Retrans: 2, Retries: 0
Se0/2
14 01:04:08
29
Retrans: 1, Retries: 0
Se0/0
13 01:09:52 607
Retrans: 0, Retries: 0
Se0/1
12 01:10:19
60
Retrans: 0, Retries: 0

RTO

Q Seq Type
Cnt Num
200 0 5
200

3642

13

360

21

R3#

Some other commands


64

Outputs

R3# show ip eigrp interfaces


IP-EIGRP interfaces for process 1

Interface
Se0/1
Se0/0
Se0/2
Se0/3
R3#

Peers
1
1
1
1

Xmit Queue
Un/Reliable
0/0
0/0
0/0
0/0

Mean
SRTT
60
607
29
24

Pacing Time
Un/Reliable
0/15
0/15
0/15
0/17

Multicast
Flow Timer
299
3031
143
50

Pending
Routes
0
0
0
0

65

R3# show ip protocols


What are these telling us?
Routing Protocol is "eigrp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
K values
EIGRP maximum hopcount 100
Variance, later
EIGRP maximum metric variance 1
Redistributing: eigrp 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.4/30
Directly connected networks
10.0.0.8/30
10.0.0.12/30
10.0.0.16/30
192.168.3.0
Routing Information Sources:
Gateway
Distance
Last Update
Neighbors
10.0.0.9
90
00:03:03
10.0.0.14
90
00:03:03
10.0.0.5
90
00:03:11
10.0.0.18
90
00:03:03

66

Outputs

R3# show ip eigrp topology


<output omitted>
P 10.0.0.0/30, 2 successors, FD is 2681856
via 10.0.0.9 (2681856/2169856), Serial0/1
via 10.0.0.5 (2681856/2169856), Serial0/0
<output omitted>

Feasible distance

P 172.16.0.0/16, 1 successors, FD is 2172416


via 10.0.0.14 (2172416/28160), Serial0/2
via 10.0.0.18 (2312192/28160), Serial0/3

Reported Distance
is less than
Feasible distance
successor
feasible successor

Feasible distance: if this router was the successor.


67

Outputs

R3# show ip eigrp topology all-links


P 10.0.0.0/30, 2 successors, FD is 2681856, serno 13
via 10.0.0.9 (2681856/2169856), Serial0/1
via 10.0.0.5 (2681856/2169856), Serial0/0
via 10.0.0.18 (3845632/3193856), Serial0/3

successor
successor
non-feasible
successor

Why does R3 show a third entry for 10.0.0.0/30?


Why is R4 a non-feasible successor?
Reported distance > Feasible distance
There is a loop via the lower (1424kps) link!!!
68

Passive Interfaces

Passive Interfaces
Two ways to prevent EIGRP from speaking sending EIGRP messages
on an interface.
1. Enable EIGRP on the interface using the EIGRP network command
and use the the passive-interface command.
Does NOT send any EIGRP messages on the interface.
No Hellos, thus no neighbor adjacency
Prefix (interface subnet) is still advertised on other interfaces
2. Do NOT enable EIGRP on the interface,
Advertise about the connected route using route redistribution
using the redistribute connected configuration command.
More complicated
Less popular
70

Passive
Interfaces

R1# show ip eigrp inter


IP-EIGRP interfaces for process 1

Interface
Se0/0
Se0/1
Fa0/0

Peers
1
1
0

Xmit Queue
Un/Reliable
0/0
0/0
0/0

Mean
SRTT
34
31
0

Pacing Time
Un/Reliable
0/15
0/15
0/10

Multicast
Flow Timer
163
147
0

Pending
Routes
0
0
0

The show ip eigrp interfaces command displays working interfaces


on which EIGRP has been enabled, but omits passive interfaces.
A failure of the interface, or making the interface passive, would omit
the interface from the output of this command.

71

Passive
Interfaces
R1(config)# router eigrp 1
R1(config-router)# passive-interface fa 0/0
R1# show ip eigrp inter
IP-EIGRP interfaces for process 1

Interface
Se0/0
Se0/1
R1#

Peers
1
1

Xmit Queue
Un/Reliable
0/0
0/0

Mean
SRTT
32
28

Pacing Time
Un/Reliable
0/15
0/15

Multicast
Flow Timer
151
139

Pending
Routes
0
0

R1(config)# router eigrp 1


R1(config-router)# network 192.168.10.0

No longer a neighbor.
Must include network command.

72

Passive
Interfaces

R1# show ip protocols


<output omitted>
Routing for Networks:
10.0.0.0/30
10.0.0.4/30
192.168.10.0
Passive Interface(s):
FastEthernet0/0

Verifying
73

Passive
Interfaces

R4(config)# router
R4(config-router)#
R4(config-router)#
R4(config-router)#

eigrp 1
passive-interface default
no passive-interface ser 0/0
no passive-interface ser 0/1

R4# show ip protocols


<output omitted>
Routing for Networks:
10.0.0.12/30
10.0.0.16/30
172.16.0.0
Passive Interface(s):
FastEthernet0/0
FastEthernet0/1

74

Summarization

75

Summarization
Benefits:
Smaller routing tables
Reduces Query scope:
EIGRP Query stops at a router which has a summary route
that includes the subnet listed in the Query, but not the
specific route listed in the Query
EIGRP supports summarization on any router in the network
Trade-offs:
Can cause suboptimal routing
Packets destined for inaccessible destinations will flow to the
summarizing router before being discarded
Note: If a packet matches two routes in the routing table, the best
match will be the route with the longest-bit-match, the route with the
longer prefix-length (subnet mask).

76

EIGRP Summarization Odds and Ends


Any EIGRP router can summarize routes.
OSPF: Summarization can only take place on the ABRs and
ASBRs.
The summary route's metric is based on the lowest metric route
upon which the summary route is based.
The summary route will use a metric equal to the metric of the
lowest metric subordinate route.
Manual summarization creates a Null0 summary on the router doing
the summarization.
R3(config)# interface serial 0/0/1
R3(config-if)# ip summary-address eigrp 1 192.168.0.0 255.255.252.0
R3# show ip route
Creates a Null0 summary route
<output omitted>
D 192.168.0.0/22 is a summary, 00:00:06, Null0

77

The Null0 Summary Route


R1# show ip route
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D
192.168.10.0/24 is a summary, 00:45:09, Null0
C
192.168.10.4/30 is directly connected, Serial0/0/1
D
192.168.10.8/30 [90/3523840] via 192.168.10.6, 00:44:56, S0/0/1
172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D
172.16.0.0/16 is a summary, 00:46:10, Null0
C
172.16.1.0/24 is directly connected, FastEthernet0/0
D
172.16.2.0/24 [90/40514560] via 172.16.3.2, 00:45:09, S0/0/0
C
172.16.3.0/30 is directly connected, Serial0/0/0
D 192.168.1.0/24 [90/2172416] via 192.168.10.6, 00:44:55, Serial0/0/1

EIGRP automatically includes a Null0 summary route as a child route


whenever both of the following conditions exist:
There is at least one subnet that was learned via EIGRP.
Automatic summarization is enabled. (By default with EIGRP)
What if R1 received a packet: 172.16.4.10
It would be discarded never looking for a supernet or default route
Regardless of ip classless or no ip classless command
Helps prevent any routing loops between the edge and ISP routers.

78

Disabling
Automatic
Summarization
172.16.0.0/16
R3# show ip route
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D
192.168.10.0/24 is a summary, 01:08:35, Null0
C
192.168.10.4/30 is directly connected, Serial0/0/0
C
192.168.10.8/30 is directly connected, Serial0/0/1
D
172.16.0.0/16 [90/2172416] via 192.168.10.5, 01:08:30, Serial0/0/0
C
192.168.1.0/24 is directly connected, FastEthernet0/0

Like RIP, EIGRP automatically summarizes at major network


boundaries using the default auto-summary command.
79

Disabling
Automatic
Summarization

172.16.0.0/16

172.16.0.0/16
R3# show ip route
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D
192.168.10.0/24 is a summary, 01:08:35, Null0
C
192.168.10.4/30 is directly connected, Serial0/0/0
C
192.168.10.8/30 is directly connected, Serial0/0/1
D
172.16.0.0/16 [90/2172416] via 192.168.10.5, 01:08:30, Serial0/0/0
C
192.168.1.0/24 is directly connected, FastEthernet0/0

Both R1 and R2 automatically summarizing.


R1 is the successor because of the difference in bandwidth.

80

Disabling
Automatic
Summarization
172.16.0.0/16
R3# show ip route
<output omitted>
D

172.16.0.0/16 [90/2172416] via 192.168.10.5, 01:08:30, Serial0/0/0

Is this the best route for all 172.16.0.0 subnets?


No, suboptimal routing may occur.
R3 will route all packets destined for 172.16.2.0 through R1.
Solution?
Need R1 and R2 to send individual subnets.
R1 and R2 must stop automatically summarizing 172.16.0.0/16.

81

Disabling Automatic Summarization


R1(config)# router eigrp 1
R1(config-router)# no auto-summary
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.3.2 (Serial0/0/0) is
resync: summary configured
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.3.2 (Serial0/0/0) is
down: peer restarted
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.3.2 (Serial0/0/0) is
up: new adjacency
<output omitted>
R2(config)# router eigrp 1
R2(config-router)# no auto-summary
R3(config)# router eigrp 1
R3(config-router)# no auto-summary

Automatic summarization can be disabled with the no auto-summary.


The router configuration command eigrp log-neighborchanges is on by
default on some IOS implementations. .
82

Disabling Automatic Summarization


R1# show ip route

C
D
C
D
C
D

192.168.10.0/30 is subnetted, 2 subnets


192.168.10.4 is directly connected, Serial0/0/1
192.168.10.8 [90/3523840] via 192.168.10.6, 00:16:55, S0/0/1
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
172.16.1.0/24 is directly connected, FastEthernet0/0
172.16.2.0/24 [90/3526400] via 192.168.10.6, 00:16:53, S0/0/1
172.16.3.0/30 is directly connected, Serial0/0/0
192.168.1.0/24 [90/2172416] via 192.168.10.6, 00:16:52, Serial0/0/1

R1 no more Null0 summary routes:


D
192.168.10.0/24 is a summary, 00:45:09, Null0
D
172.16.0.0/16 is a summary, 00:46:10, Null0
What does this mean?
This means any packets for their parent networks that do not match a
child route, the routing table will check supernet and default routes.
Unless no ip classess is used

83

Disabling Automatic Summarization


R2# show ip route

D
C
D
C
C
C
D

192.168.10.0/30 is subnetted, 2 subnets


192.168.10.4 [90/3523840] via 192.168.10.10, 00:15:44, S0/0/1
192.168.10.8 is directly connected, Serial0/0/1
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
172.16.1.0/24 [90/3526400] via 192.168.10.10, 00:15:44, S0/0/1
172.16.2.0/24 is directly connected, FastEthernet0/0
172.16.3.0/30 is directly connected, Serial0/0/0
10.0.0.0/30 is subnetted, 1 subnets
10.1.1.0 is directly connected, Loopback1
192.168.1.0/24 [90/3014400] via 192.168.10.10, 00:15:44, S0/0/1

R2 no more Null0 summary routes :


D
192.168.10.0/24 is a summary, 00:00:15, Null0
D
172.16.0.0/16 is a summary, 00:00:15, Null0

84

172.16.0.0/16

R3# show ip route

C
C
D
D
D
C

172.16.0.0/16

192.168.10.0/30 is subnetted, 2 subnets


192.168.10.4 is directly connected, Serial0/0/0
192.168.10.8 is directly connected, Serial0/0/1
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
172.16.1.0/24 [90/2172416] via 192.168.10.5, 00:00:11, S0/0/0
172.16.2.0/24 [90/3014400] via 192.168.10.9, 00:00:12, S0/0/1
172.16.3.0/30 [90/41024000] via 192.168.10.5, 00:00:12, S0/0/0
[90/41024000] via 192.168.10.9, 00:00:12, S0/0/1
192.168.1.0/24 is directly connected, FastEthernet0/0

Why does R3s routing table now have two equal-cost paths to
172.16.3.0/24?
Shouldnt the best path only be through R1 with the 1544-Mbps link?

85

Disabling
Automatic
Summarization

172.16.0.0/16

172.16.0.0/16
R3# show ip route
<output omitted>
D

172.16.3.0/30 [90/41024000] via 192.168.10.5, 00:00:12, S0/0/0


[90/41024000] via 192.168.10.9, 00:00:12, S0/0/1

The slowest link is the 64-Kbps link

86

Manual Summarization

EIGRP can be configured to summarize routes, whether or not


automatic summarization (auto-summary) is enabled.
Modified topology.

87

Manual
Summarization

R3(config)# interface loopback 2


R3(config-if)# ip address 192.168.2.1 255.255.255.0
R3(config-if)# interface loopback 3
R3(config-if)# ip address 192.168.3.1 255.255.255.0
R3(config-if)# router eigrp 1
R3(config-router)# network 192.168.2.0
R3(config-router)# network 192.168.3.0

Add two more networks to R3.


Configure EIGRP network statements.

88

Manual
Summarization
192.168.1.0/24,
192.168.2.0/24,
192.168.3.0/24

192.168.1.0/24,
192.168.2.0/24,
192.168.3.0/24

Only pertinent routes shown

R1#
D
D
D

show ip route
192.168.1.0/24 [90/2172416] via 192.168.10.6, 02:07:38, S0/0/1
192.168.2.0/24 [90/2297856] via 192.168.10.6, 00:00:34, S0/0/1
192.168.3.0/24 [90/2297856] via 192.168.10.6, 00:00:18, S0/0/1

R2#
D
D
D

show ip route
192.168.1.0/24 [90/3014400] via 192.168.10.10, 02:08:50, S0/0/1
192.168.2.0/24 [90/3139840] via 192.168.10.10, 00:01:46, S0/0/1
192.168.3.0/24 [90/3139840] via 192.168.10.10, 00:01:30, S0/0/1

Instead of sending three separate networks, R3 can summarize the


192.168.1.0/24, 192.168.2.0/24, and 192.168.3.0/24 networks as a single route.
89

Determining the Summary EIGRP Route

1. Write out the networks that you want to summarize in binary.


2. Find the matching bits.
Count the number of leftmost matching bits, which in this example is 22.
This number becomes your subnet mask for the summarized route: /22
or 255.255.252.0.
3. To find the network address for summarization, copy the matching 22 bits
and add all 0 bits to the end to make 32 bits.
The result is the summary network address and mask for 192.168.0.0/22
90

Configure EIGRP
Manual
Summarization

192.168.0.0/22

192.168.0.0/22

Router(config-if)# ip summary-address eigrp as-number network-address


subnet-mask
R3(config)# interface serial 0/0/0
R3(config-if)# ip summary-address eigrp 1 192.168.0.0 255.255.252.0
R3(config)# interface serial 0/0/1
R3(config-if)# ip summary-address eigrp 1 192.168.0.0 255.255.252.0
R3# show ip route
Creates a Null0 summary route
<output omitted>
D 192.168.0.0/22 is a summary, 00:00:06, Null0

Because R3 has two EIGRP neighbors, the EIGRP manual summarization


in configured on both Serial 0/0/0 and Serial 0/0/1.

91

Verify EIGRP
Manual
Summarization

192.168.0.0/22

192.168.0.0/22

R1# show ip route


<output omitted>
D 192.168.0.0/22 [90/2172416] via 192.168.10.6, 00:01:11, Serial0/0/1
R2# show ip route
<output omitted>
D 192.168.0.0/22 [90/3014400] via 192.168.10.10, 00:00:23, Serial0/0/1

Fewer number of total routes in routing tables


Faster routing table lookup process more efficient.
Summary routes also require less bandwidth and memory
Single route can be sent rather than multiple individual routes.
NOTE: The minimum metric of specified routes is used as the metric of the
summary route.

92

Default Route

93

EIGRP Default
Route

Default Route

Redistribute
default static
route in
EIGRP
updates

The ISP router in our topology does


not physically exist. By using a
loopback interface, we can simulate
a connection to another router.

R2(config)# ip route 0.0.0.0 0.0.0.0 loopback 1


R2(config)# router eigrp 1
R2(config-router)# redistribute static

Unlike RIP and OSPF, EIGRP does not propagate a 0.0.0.0 0.0.0.0 by
default.
Two ways to propagate a static default route in EIGRP:
Redistribute static
Network command
redistributestaticwill redistribute all static routes by default.

94

EIGRP Default
Route

Default Route

Redistribute
default static
route in
EIGRP
updates

Only static default route shown,


other output omitted.

R1# show ip route


Gateway of last resort is 192.168.10.6 to network 0.0.0.0
D*EX

0.0.0.0/0 [170/3651840] via 192.168.10.6, 00:02:14, S0/0/1

D: This static route was learned from an EIGRP routing update.


*: The route is a candidate for a default route.
EX: The route is an external EIGRP route, in this case a static route outside
of the EIGRP routing domain.
170: This is the AD of an external EIGRP route.
95

EIGRP Default
Route

Default Route

R2(config)# ip route 0.0.0.0 0.0.0.0 loopback 1


R2(config)# router eigrp 1
R2(config-router)# network 0.0.0.0

The network 0.0.0.0 command will propagate a default route as a result of


the static default route.

96

EIGRP Default-network
Default Route

Redistribute
default static
route in
EIGRP
updates

There is another method to propagate a default route in EIGRP, using the


ip default-network command.

97

EIGRP Defaultnetwork

default-network

R2(config)# ip default-network 10.0.0.0


R2(config)# router eigrp 1
R2(config-router)# network 10.0.0.0
R2(config-router)# network 172.16.0.0
R2(config-router)# network 192.168.10.0

ip default-network network-number
network-number - Network of last-resort gateway that will be announced to all
other routers.
R2s routing table:
10.0.0.0 will be shown as the gateway of last resort
This network is propagated in EIGRP as a gateway of last resort
If a subnet is specified IOS will install a static route in the running-config

98

A few commands

99

show ip eigrp traffic

Displays the number of various EIGRP packets sent and received

100

debug ip eigrp
traffic
Displays the types of
EIGRP packets sent
and received by the
router on which this
command is executed.
See example in Chapter
2 for a detailed
explanation of this
output.

101

debug ip eigrp
Displays general
debugging information.
See example in
Chapter 2 for a detailed
explanation of this
output.

102

Thats all for tonight, good night!

103

CIS 185 CCNP ROUTE


EIGRP Part 1
Rick Graziani
Cabrillo College
graziani@cabrillo.edu
Last Updated: Fall 2010