You are on page 1of 8

Switch 1:

Switch>
Configuring Vlan 1 for Switch Management Switch>en
Switch#conf t
Switch(config)#hostname S1
S1(config)#do sh vlan
S1(config)#int vlan 1
S1(config-if)#ip addr 192.168.1.10 255.255.255.0
S1(config-if)#no shut
S1(config-if)#exit
S1(config)#

Switch 2:
Switch>
Switch>en
Switch#conf t
Switch(config)#hostname S2
S2(config)#do sh vlan
S2(config)#int vlan 1
S2(config-if)#ip addr 192.168.1.11 255.255.255.0
S2(config-if)#no shut

Switch 3:
Switch>
Switch>en
Switch#conf t
Switch(config)#hostname S3
S3(config)#do sh vlan
S3(config)#int vlan 1
S3(config-if)#ip addr 192.168.1.12 255.255.255.0
S3(config-if)#no shut
Switch 1:
Configuring Trunk ports S1#sh int fa0/11 switchport
S1#conf t
S1(config)#int fa0/11
S1(config-if)#switchport trunk encapsulation
dot1q
S1(config-if)#switchport mode trunk
S1(config-if)#no shut
S1(config-if)#exit
S1(config)#

Do same for fa0/12

Put rest of ports to access mode:


S1(config)#interface range fa 0/1 - 10
S1(config-if-range)#switchport mode access
S1(config-if-range)#interface range fa 0/13 - 24
S1(config-if-range)#switchport mode access
S1(config-if-range)#exit
S1(config)#

Switch 2 & 3:

Same as above
Switch 1:
Configuring VTP S1#sh vtp status

S1#conf t
S1(config)#vtp domain MDXWORLD
S1(config#exit

Switch 2 & 3:
S2(config)#vtp mode client
S2(config)#exit
Switch 1:
Configuring VLAN (only done on VTP server) S1#sh vlan

S1#conf t
S1(config)#vlan 10
S1(config-vlan)#name SALES
S1(config-vlan)#exit

S1(config)#vlan 20
S1(config-vlan)#name MARKETING
S1(config-vlan)#exit

S1(config)#vlan 30
S1(config-vlan)#name ENGINEERING
S1(config-vlan)#exit

Try ping from 1 PC to the other


Switch 2:
Adding ports to VLAN S2#sh vlan

S2#conf t
S2(config)#int fa0/8
S2(config-if)#switchport mode access vlan 10
S2(config-if)#exit

Same on Switch 3

Again, try ping from 1 PC to the other


Switch 2:
Adding ports to VLAN S2#sh vlan
(with new ip addressing scheme to reflect vlan nos.) S2#conf t
S2(config)#int fa0/8
S2(config-if)#switchport mode access vlan 20
S2(config-if)#exit

Same on Switch 3 (add to vlan 10)

Again, try ping from 1 PC to the other


Switch 1:
Creating vlan interface on L3 Switch S1#sh vlan
S1#sh ip int br
(for routing between vlans)
S1#conf t
S1(config)#interface vlan 20
S1(config-if)#ip addr 192.168.20.1
255.255.255.0
S1(config-if)#exit

S1(config)#interface vlan 10
S1(config-if)#ip addr 192.168.10.1
255.255.255.0
S1(config-if)#exit

To turn on routing on L3 Switch:


S1(config)#ip routing

Again, try ping from 1 PC to the other

You might also like